Unable to connect Roon Arc, why?

Roon ARC unable to connect to my core. Error message below. Help please.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“99.aaa.bbb.ccc”,“router_external_ip”:“null”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

As original thread was resolved I moved your post to it’s own new support thread where it will not get missed.
Can you please provide details of your equipment and network setup.

1 Like

Sure. My router is a Netgear Orbi RBR50. Firmware version V2.7.3.22. The UPnP is enabled. My core is sonictransport by Small Green Computer. I manually added the sonictransport as a service on the port forwarding page of the Orbi set up page.

My ISP provider is Rogers in Toronto.

Please let me know if you need anything else. Thanks for your help.

Thank you @cavawood. Can you please fill in a bit more details, it appears you have either two routers in your network or UPnP is not configured correctly based on the error message, but not completely sure.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Robert - After much effort, I figured out how to connect. I’ll try it out tomorrow. Thanks for the support.

1 Like

@cavawood, have you had any success?

Yes. I changed settings in the modem and I am now able to connect. ARC working smoothly. Thanks again.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.