Unable to connect to roon core on NAS remotely via ARC

Roon Core Machine

Running roon core on Synology 418play with extra Ram and external SSD for database

Networking Gear & Setup Details

Linksys smart wifi

Connected Audio Devices

Number of Tracks in Library

Description of Issue

No problem connecting locally via roon app. Everything works fine this way. However cant connect to the core remotely using Arc. The error message seems to suggest that the problem is confusion over multiple NATS. See error message below:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 45.aaa.bbb.ccc:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“45.aaa.bbb.ccc”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have contacted my ISP and he says he has a core router that does NAT and is reluctant to open up a port for me for security reasons?

Any advice would be geatly appreciated. I am wholly ignorant about network tech so please assume that i am a dummy!

Welcome to the community, @Michael_JENKINS1.

The diagnostics you’ve provided suggest there is a redundant layer of network address translation preventing port forwarding.

This can either be at the local-network level (commonly as a result of two routers), or at the level of your service provider (in the form of carrier-grade NAT).

If your setup involves an ISP-provided gateway (modem/router combination) and your own third-party router:

  • In the web administration interface of the ISP-provided gateway (modem/router combination), enable Bridge Mode or equivalent, where the ISP-provided gateway does not have DHCP routing enabled.

  • Alternatively, if you have already created a manual port forwarding rule in your 3rd party router, you can add an additional rule to forward the port through the ISP/second router.

If you only have one router in your setup or your modem is already in Bridge mode, please take a look through our list of known router and internet service provider solutions, as other users may have already encountered the same situation: ISPs and Routers: List of Known Solutions and Workarounds

You can reach out directly to your service provider to ask if they support port forwarding; this question will often enough to prompt them to explain whether or not the carrier-grade NAT they’ve implemented can function with ARC.

More specifically, you can pass along the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

If you’re unable to locate an existing solution in our #support:port-forwarding-resources subcategory, please reach out to the Roon support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Is your ISP a single person?

If it is as you’ve suggested that your ISP is giving you a NAT’d connection, then your ISP needs to setup a port forwarding rule on his core router to your router. Which when he does this, you would then need to setup the port forwarding rule from your router to the Roon core.

If he won’t do this then your only other option is to run a VPN like tailscale.

1 Like

Thanks for your response Dan. Yes he is a one man band, supplying internet to villages using a local wireless network with a pole on the village hall and pole on the roof.
It doesn’t look as if he is going to agree to create port forwarding on his router. Just waiting on his final response on the issue.
I guess I may have to look into tailscale?

1 Like

Well, that is your option at this point, until Roon comes up with an alternate solution.

I notice that one of the suggestions by Martin is that I ask my ISP for a static IPv4 static address. Is this something that my ISP will be more comfortable with and would that enable me to solve the problem?

You can ask and see. But he doesn’t generate a public IP, that is the actual ISP that he is getting his service from. It might be expensive as well if he could accommodate at all.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.