Unable to Download HQPlayer NAA on New Ultrarendu

Received a brand new Ultrarendu on Friday have owned pretty much all the rendus off/on over the years so very familiar with them. I went to the Available apps in the Ultrarendu UI and selected to install HQPlayer NAA. No matter what it hangs in the same “place” (see pic) and the install never finishes. I updated the Ultrarendu firmware even though it said it was OK and it ran successfully. I have rebooted the device MANY times since Friday, tried different ethernet cables directly from my router to the device and it still wont install. Is there suddenly a new version incompatibility b/t Sonore and HQPlayer NAA? Ultrarendu is version 2.9 and HQPlayer NAA is version 4.2.0 (again these are only ones “available “ in the Ultrarendu available apps section of its UI. Any ideas??

I would contact Sonore support in this case. Perhaps you have a bad microSD card or a corrupted image that shipped with your new device.

I was able to get the NAA loaded. Mr Gillis said they had server issues over the weekend! Loaded just fine last PM….BUT…now i cant get HQPlayer to place nice with roon! Last time I tried this was 2 yrs ago so may need group think on what I am doing wrong! I keep getting the error “playback stopped because roon failed to connect to HQPlayer.” My roon core is on a sonic transporter i9 with HQ Player embedded. That is hardwired via ethernet to the router. The NAA is the Ultrarendu which is hardwired to another eero router on same mesh network in the Man Cave with ethernet in, USB out to OPPO 205 DAC connected to Anthem receiver. In prev house this all worked fine! So something is wrong now perhaps with settings?! Does anyone see anything wrong via pics below? Roon setting was HQplayer embedded with “localhost”…do I need to try URL or something diff there? On HQPlayer settings it see the Ultrarendu in NAA, etc…I am at a loss but HQPlayer setting can be finicky if ur like me and rusty using it!

Hi @Douglasmaurer ,

I can’t see anything wrong with your settings. I had a similar error message from HQP recently using the Linux Desktop version. After restarting my microRendu HQP was unable to find it as an NAA backend.

I was able to get HQP to see the microRendu by changing the NAA backend to IP6, saving the settings and then changing it back again.

In this recent thread Jussi said similar behaviour could be associated with allowing DHCP to allocate an IP for HQP and that it is best to use a fixed IP address for HQP in the server.

Thanks, Andybob, will try the reboot and IP6 setting when I get home tonight. may have to “google” how to set a fixed IP address for HQP specifically for the eero router…


I’ve edited my post to add a link to Jussi’s post and clarify what he said. You will see that he is referring to the server rather than the router. I’m not sure whether you have access to a terminal into your SonicTransporter server to check on that sort of thing.

Looks OK, is the HQPlayer Embedded version up to date? It would be good to enable log file and check if there is any activity visible in HQPlayer log file when Roon is trying to connect?

Is HQPlayer license valid (you can see from /about page)? If HQPlayer is in trial mode, and the trial period has expired (30 minutes since start), you need to restart HQPlayer/sonicTransporter for another 30 minute trial period.

Thanks all for your help! Update:

  1. HQPlayer and Roon can now “find” each other!
  2. I have no issues with PCM upsampling.
    3 i am having issues with DSD upsampling!
    a. See attached settings part 2…any obvious issues…seems like a “horsepower issue “ as occ got playback but most of time just would show in roon, “playing x # of tracks”, stream purity light would come on in roon, would show 1st track, but no sound and no movement even though it was supposed to be playing? Should I just start at DSD 64 and work up rather than 512 to now 256 or is something else the issue.
    b. Regarding IPv6…I noticed this was “on” for my Eero network settings…should I turn it off in both HQPlayer and Eero or leave it on in both? Shouldnt matter or might cause problems!
    c. I didnt try the terminal access fixed IP address change on the sonictransporter since can get PCM playback and was nervous to muck with it!

Two issues:

  1. Uncheck the “Auto rate family”
  2. Set “Rate limit” to 22579200

Otherwise at least all 48/96/192k source content will fail to play.

One potential issue: for 1x and Nx oversampling filters, use the -2s suffixed version of the filter when available. Otherwise it will take a long time to initialize and take a lot of CPU power.

1 Like

Thanks so much! That did the trick! Working great in DSD256!


Greetings! After several weeks of success, I seem to of lost the ability again to play any music via HQ player and NAA b/t my Sonicorbitor i9 and my Ultrarendu into my Oppo 205. The Roon ready function on the ultrarendu works fine—listening to it right now in fact. But every time I’ve switched into HQ player and NAA it looks like it’s going to start playing as in the pictures previously posted above, but nothing happens. It just sits there And no sound is produced even though roon ‘lights up” and seems to try to start. I’m not sure if I have some thing wrong with my settings again or if this is some sort of network issue. I have tried setting my Eero router both on and off IPV6 but it doesn’t seem to matter which way I have it set I can’t get sound either way. I have tried both SDM and PCM without success. Any help would be much appreciated! Settings screenshot attached!

Thanks! Doug

It definitely seems to be something with the IP V6 as I’m noticing when I don’t have it set, the ultrarendu doesn’t appear and when I do have it set box checked, it does appear. I guess I thought it would work with the router set into either mode I have been using IP V6 as I was testing it out for the ARC beta testing program see screenshots

You seem to already have log file enabled. It is good to check the log file (/log URL in web interface). First attempt to play from Roon and then check the log file around that moment. Errors lines are prefixed with ‘!’ or "!’ marker character. Warnings or unexpected behaviour are marked with “?”.

Usually IPv6 works regardless of router settings. Router doesn’t need to know about it, when there’s no specific IPv6 infrastructure, the protocol stacks just fall back to automatic local network addressing. IPv6 can also occupy entire IPv4 network and operate through compatibility addressing.

Thanks, Jussi! Def seeing some errors in the log but not sure what they mean/how to troubleshoot them. The attached screenshots are after I turned off ipv6 and rebooted the Network/router…still cant get anything to play.

1 Like

The configuration file section for HQPlayer’s loudspeaker layout (aka channel balance) processing has become corrupted. Are you using the speaker setup feature? If so, please check the values there. Or if you are not using it, disable this feature.

If it doesn’t recover, you can edit the “<speakers>” element in /etc/hqplayer/hqplayerd.xml file. Please email a copy to me, I’m curious which way it has gone wrong.

Interesting! I had filters loaded in matrix, but had disable that thinking maybe that was creating too much of a load although it has been working just fine previously. I have sent you a private message with a link to the log file.