Unable to install Roon Server on DS218+

Trying to install Roon Server on Synology DS218+ but seems cant get it right…
Before heading to install I have:

  1. Created a shared folder “RoonServer” on my DiskStation.
  2. Changed Trust Level to “Any Publisher” in package center.
  3. Downloaded “RoonServer_Synology_x86_64_beta_2020-06-24.spk”

Was hit with following error

Suspect there is an issue when downloading installation file, is there a way to download the package and install it offline?


Hello and welcome to the community.

Have you read the information in the link posted here: https://kb.roonlabs.com/Roon_Server_on_NAS

I don’t use a NAS for Roon so cannot offer input other than what the information in the link and other posts in the forum provides.

Hi Mike, yes I have been looking at that page for a few days in fact before deciding to switch to NAS as Roon Server.
Hardware wise it seems to meet the min requirement of Intel 64-bit x86 CPU, upgraded RAM to 6GB also…
Tried the older version of spk, still no luck…

The latest version of Roon prior to the beta release installs and works flawlessly on my DS218+ running ‘DSM 6.2.3-25426 Update 2’ (the latest of today).

How I did it - a how to:

  1. Download the latest installer for Synology (x64) here: https://roononnas.org/builds/Synology/RoonServer_Synology_x86_64_2018-03-07.spk
    (try this one first before the Beta release).

Note: Be sure to download the file with your pc or mac and not on the NAS itself.

  1. Login to the NAS from your web browser on your pc/mac on an account with ADMIN privileges.

  2. Open the ‘Package Center’.

  3. In the upper right corner the window of the ‘Package Center’ choose ‘Manual Install’ and ‘Browse’ to the file you downloaded above and choose it. Follow the instructions.

If the installation still fails please go the ‘Control Panel’ on the NAS and open ‘Info Center’ and verify that you indeed have an Intel CPU = ‘INTEL Celeron J3355’.

Let us know how things turns out.

The Roon Server runs without a glitch on my DS218+ with only 2GB of memory.

I use DSP Convolution for room correction (full bandwidth 20-20.000Hz) and also DSP Sample Rate Conversion.

The DS218+ handles the Roon DSP without a glitch of any kind.

CPU utilisation for the Roon Server is <20% and memory utilisation is <750MB when handling a 24 bit 384kHz DXD file. I’m impressed.

Hi KBSmidt,

Thanks for your advice. Seems it just doesn’t work on my NAS :frowning:

Thus I bought a NUC and installed ROCK on it, works like a charm :grinning:

Still I have attached a screenshot of the error msg here, wish it can help the community to identify the cause, and maybe save other user from similar problems.

Hi Sidney_Qin,

The NUC with ROCK is a killer solution, no doubt. :smiley:

  1. I wonder why the NAS tries to download an ‘Installation Archive’ from the Roon Labs website.
    Have you downloaded the installation package to you pc/mac and chosen to install it manually as I described?

  2. The NAS do have access to the Internet via an internet router?

Best Regards,

Can you try to manually add a DNS entry to your network interface of the DS218+?
Best would be to try Googles DNS as a test (

Afterwards try the Roon Server installation again.

The NAS installers do not include the linux build for Roon Server itself. The linux Roon Server version is downloaded during installation from the Roonlabs website. This makes sure, the most recent version of Roon Server is always used and there is no need for an updated installer for NAS, for every new version of Roon Server. :slight_smile:

@KBSmidt, I am impressed genuinely that you are able to run with convolution and DSP with a Synology DS218+! I tried upsampling to DSD on mine with Logitech Media Server and the Synology just choked completely. As Roon is even more cpu-intensive, I am curious about your DSP settings. What have you been able to do with DSP?

Thank you for your explanation.

In that case it seems that Sidney_Qin’s NAS is unable to reach the roonlabs website.

@Sidney_Qin: for further assistance I believe you have to post logfile(s) from your NAS.

Hi Mike_Rubin,

DSD related I do Convolution and Sample Rate Conversion.


Sample Rate Conversion
Sample Rate Conversion = MAX PCM RATE
Sample Rate Conversion Filter = PRECISE LINEAR PHASE
DSD Processing Settings, Sigma-Delta Modulator = 5TH ORDER(CLANS)
Enable Native DSD Processing = No
DSD TO PCM Gain = +6DB

I did also use ‘Parametic EQ’ at a time without a glitch either but don’t use it anymore as I optimised the response in Room EQ Wizard (REW).

I have been running a NUC with ROCK and upsampling everything to DSD256. Other than some concerns about overheating my cpu, that has worked well.

Just for grins, after reading your post, I installed Roon Server on my DS218+. It installed easily, seemed to be making good progress in installing my 7tb library despite the NAS’ 2gb memory, and even played some FLAC files while creating the database, so I decided to give my DSD256 DSP settings a go. Big mistake. Immediate crash.

I will let Roon Server build a database until it runs out of RAM and then will try your DSP settings, although I will see if native DSD can play without going the DoP route. Thanks for providing the settings.

You’re welcome.
Let’s know how your testing turns out.

I ordered extra memory for my NAS.

I just ordered extra memory, too. Database loading has slowed to a crawl.

And I just uninstalled it, at least pending the arrival of the 8gb of RAM I ordered today. It kept choking when adding albums, even though it hogged the NAS’ CPU and memory resources. I had to stop and restart the service four or five times to refresh it before giving up.

Considering that this NAS’ CPU isn’t as powerful as the base Nucleus’, it makes sense that it couldn’t handle managing a collection larger than what the Nucleus can handle. I might try again when I have more RAM running, but I am sure it makes more sense just to stick to my i7 NUC with ROCK.

FWIW, though, I had zero trouble installing and configuring the Roon Server package.