Unable to Port Forward on 4G Router (Gini Router R610)

Description of Issue:

Hello Everyone,
I’m using a Windows 11 laptop, everything works great exept the Roon ARC feature.
This is the error I get:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

So I did a manual port forwarding:

Nothing worked…
And Yes, DMZ is disabled.

Some Details About My Networking Gear

  1. I have a 4G router that connects to the internet via a SIM card to a 4G tower.
  2. I live in Israel and my ISP is Pelephone
  3. My router is called Gini Router R610 and i’m using it via wifi.
  4. I also use a wifi extender called Edimax EW-7438RPn Mini
  5. I don’t use any VPN’s or proxies.
Other things I tried to do:
  1. Open the port on my firewall and check that Roon and RAAT is not blocked by windows firewall.
  2. Use “Simple Port Tester” to see if the port is open; it failed.
  3. Rule out my wifi extender and connect to my router directly.
  4. Use DMZ.

Nothing worked.

For context,
I once tried to just Plex server and I have encountered the same problem. Unfortunately I never managed to fix it and now the same happens with Roon ARC and this is my last resort.

Any kind of help will be very appreciated!!

Hi Ron,

I am no guru, but in the picture under protocol now is shown “TCP” is this the only option or do you have the option TCP & UDP? If so, could you try that one.

After applying the rule, did you reboot your core (i think that is your Windows 11 laptop)?

Kind regards,


Sorry it took long to replay.
I have tried this before, but gave it one more try. And It gave me the same error.

I think it’s use down to me having a 4G Router the connects to a cell tower.
Maybe the internet infrastructure of the mobile cell tower is just different?
Because I think my IP is shared with all the people that use the same cell tower as me.

Hi @Ron_Oren,

Please accept my apologies that you’ve had to endure such a long wait time for a staff response to your issue.

At this time, port forwarding will not automatically configure (and will not configure the majority of cases via supported manual configuration) if you have a 4G router in your setup. If you have an additional router, it’s possible you could reconfigure your network infrastructure to securely allow for port forwarding via a different external routable IP.

However, you’ll likely have to pursue one of the methods involving Tailscale or VPNs in our #tinkering and #roon sections. I recommend searching there.

This topic was automatically closed after 43 hours. New replies are no longer allowed.