Unable to setup ARC with port forwarding from ASUS Router

So, how come port forwarding works for my plex server on the sae network?
What’s the difference between Plex and Roon in this case?

Except his Asus is showing RFC1918 on WAN. That indicates that the ISP provided modem is NATTing as he indicated there is no bridge mode available on his modem?

If his ISP provided modem shows RFC1918 on the WAN as well then there is NATTing also happening on the ISP network (or they are wrong about his modem not being able to bridge).

Also, why does the Roon output clearly show “MultipleNatFound” on some posts but not others like this one?

Ah my mistake, thought he was saying his wan address was 192…… not the wan address on the ASU’S.

In that case with a public wan address it should be working

@Patrick_Fitzgerald try grc shields up to see if the port forward is available on the outside

No idea. I think that would be something Roon would have to answer. Are you doing port forwarding on both devices for Plex?

By devices do you mean both routers? if that is the case, no, only on my ASUS router, I haven’t touched the ISP Router/Modem. This is what puzzles me… port forwarding works without issue on Plex but on Roon I can’t get it to work.

Yes, both devices as in your router and the ISP modem. I have no idea why Plex works but Roon doesn’t (are you sure you even need forwarding for Plex?) but I’ve seen reports of users doing the forwarding on both devices (if they are unable to get their modem into bridging) to get ARC working.

Plex only works outside a local network with Port Forwarding. I have tried setting up the ISP modem for Port forwarding as well, using the instructions by Robert_F above but it doesn’t work (I may be doing something wrong). Here is how I have set up port forwarding on my ISP Router:

Is your Roon Core? ARC only uses one port and you are showing a range in your screenshot. You need to check Roon remote > Settings > Roon ARC for the port.

Yes, that’s the IP of the Roon core. As for the range, the interface doesn’t seem to allow me to put a single port. How can I contact ROON support about this issue?

Actually, my mistake, it should be the IP of the ASUS router.

Just wanted to say that I had an identical error message with an ASUS mesh router and an upstream ISP router, apparently with double NAT. I followed Robert’s instructions above for port forwarding on both router with instant success. Roon ARC set up in Roon immediately.

My previous mistake was having the port forwarding set to the Roon address on both routers, instead of having the ISP router set to the address of the ASUS router.

I was about to ask my ISP provider to set the ISP router to bridge mode, but now I don’t have to (I would have lost a telephone service that plugs into that router and would have needed to buy other equipment to keep it).

1 Like

Correct. Did you get this squared away?

I’m afraid I didn’t get this sorted. My ISP even disabled NAT on their side but I’m still unable to set up port forwarding for Roon Arc. I’d like to try port forwarding one more time on the ISP router. Which data should I enter here apart from the IP of my ASUS Router?

I am trying this again, first time no luck, I must be doing something wrong somewhere!
In the WAN host IP address what could I put?

I am not sure about the WAN Host IP Address. Does this work if you leave it blank (no “0” in every field)?

Hi Robert, Thanks for your reply. I’m afraid it doesn’t work. I have tried putting 0s in the WAN IP Address. Have double checked port forwarding settings in ASUS Router…still no luck. I have checked the procedure and settings for port forwarding in my Plex server on my NAS to compare and its same procedure. Here ar the diagnostics from ROON CORE:
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

What is the brand and model of the Euskaltel router they provided to you?

It’s a ZTE F6640

Seems to be finally working. I rebooted the ISP router. I will test for a day and report back.
Thank you Robert. Your instructions were very helpful.


Patrick, excellent, I marked this as solved. Please update if anything changes, and enjoy the music!

1 Like