Unable to setup ARC with port forwarding from ASUS Router

Roon Core Machine

ROCK installed on NUC8I3BEH2

Networking Gear & Setup Details

NUC HARD WIRED BY ETHERNET TO ASUS ROUTER RT-AC87U connected to ISP ZTE ROUTER

Connected Audio Devices

Yamaha a-s801 and raspberry pi with volumio as endpoint.

Number of Tracks in Library

Description of Issue

I am unable to get port forwarding working from my Roon Rock to use ARC.
I have tried both automatic and manual configuration following the guides given on ROON website. On the same network I have set up port forwarding for PLEX which works perfectly without issue. Would really appreciate some help on this.
Here is the diagnostics data:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 62.99.104.239:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Looking forward to using this new feature. Thanks in advance!

What country are you in and what ISP are you on.

Hi, I’m in Spain using Euskaltel.

Read this post as you have two routers

I have checked other posts suggesting using ISP router in bridge mode, unfortunately this is not possible with the ISP router. In any case, Plex functions well with port forwarding in the current network setup. I use the ISP router for internet access only.

I think I need to set up port forwarding on my ISP router. Here is a screen grab, I’m unsure what to put, for example, the IP address of my own router in LAN Host? and the port of the rock in LAN Host Port? :

I’m guessing this screenshot is from your “ISP ZTE ROUTER” which I’m guessing is your ISP provided modem?

Patrick, you will need to configure both your ISP router and your ASUS router for port forwarding. On the screenshot you showed for Port Forwarding, I would recommend the following:

  • Name is probably something such as Roon or Roon ARC
  • Protocol: If TCP/UDP (or Both) is an option, I would select that. Otherwise start with TCP.
  • I believe you can leave the WAN Host IP Address blank
  • For LAN Host, this should be the IP address of your ASUS router
  • For WAN Port, you will need to check the Settings → Roon ARC on your Roon Core for the port identifed. In my case, it was 55002, but it may be different for others. Put this port number or a range of 1-2 below or above it, to provide you some options.
  • Repeat this for the LAN Host Port.

Next you will need to do something similar on the ASUS router. The only difference is that on the ASUS router for the Port Forwarding configuration, you will need to supply the IP address of your Roon Core server in the Internal IP Address dropdown list.

Does this help?

Yes, it is. Another option would be to get my ISP to deactivate the NAT on their router and only have it enabled on mine?

Yes, it may be possible to configure you ISP router in bridge mode and use your ASUS router as your only router on your network. Firewall, DHCP, and other services need to be supplied by your ASUS router then.

Yes, I will certainly try that…kind of makes sense! Thank you!

1 Like

Unfortunately my ISP router cannot be configured in bridge mode, I have checked with them. But NAT can be deactivated I believe.

De-activating NAT may be the quickest test, but not sure what that does with your ASUS router and other services both routers provide. If you can re-activate NAT, then maybe try and see what happens.

I’m lost. Why are we assuming double NAT here? I see no indication of it here:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 62.99.104.239:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“x.x.x.x”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s=“[http://schemas.xmlsoap.org/soap/envelope/\](http://schemas.xmlsoap.org/soap/envelope/\)” s:encodingStyle=”[http://schemas.xmlsoap.org/soap/encoding/\](http://schemas.xmlsoap.org/soap/encoding/\)“><s:Body><s:Fault>s:ClientUPnPError718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Shouldn’t we actually confirm the presence of double NAT (and where it is occuring) before we go disabling NAT on devices?

On your Asus, what WAN IP is shown?

192.168.0.128

OK, so you are double NAT’d. If you can’t disable NAT/enter bridge mode on your modem you will have to do port forwarding on both (Asus and modem). Just follow Robert_F’s initial posts for both devices.

Have just called ISP and they will disable NAT as bridge mode is not possible.
Lets see if that solves the problem. Thanks for your help.

Even better.

That’s a CGNAT address, you’re basically stuffed

The “double” NAT is not occurring at his end it is the ISP, they are nat’ing multiple customers behind a single public ip so cannot honour his wanting to use tcp/50000