Unable to setup ARC

Roon Core Machine

Innuos Zenith Mk3

Networking Gear & Setup Details

Vodafone Station

Description of Issue

When trying to setup roon ARC I get the following error:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I have no idea what to do. My Innuos server already has a static IP (, upnp is enabled and the port 55002 matches that in the roon settings.

What went wrong here?

Hey @Daniel_Appel,

Thanks for writing in, and I’m sorry to hear you’re running into issues getting Arc up and running.

From the screenshot you’ve shared, it looks like you’re trying to set Arc up through an IPv6 IP, which is not currently possible. Do you have the option to enable an IPv4 IP, and disable the IPv6 address? Or, if you can enable your router into bridge mode, that may also help.
You may have to contact your ISP to get this information.

With that, here is another thread based on the Vodafone router you mention you have in your setup details: Vodafone Italy w/ Vodafone Power Station: Port Forwarding Required Manual Configuration

Please let me know if this helps, I’ll be monitoring this thread for your reply :pray:

Found a solution here: Vodafone Germany and Fritz Box 6690 Cable: 502 Error in Port Forwarding Diagnostics - #35 by Suedkiez

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.