Unexpected error loading album. (unauthorized)

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus Roon Version 1.8 (build 764) Stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Arris Surfboard DOCSIS 3.0 Cable Modem and WiFi Router connected via ethernet to Linksys MX 5 Velop AX Whole Home WiFi 6 System
Nucleus connected to Linksys MX5 via ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Nucleus connect to Lampizator Amber 3 via USB

Description Of Issue

I can not access new music in Tidal. When I select album not in library I get the below message.

I am not sure this has anything to do with it but it is spinning like adding music but nothing to add. Also error message Metadata improver: Halted. Ronn needs software update.

I have tried restarting both routers, I rebooted the nucleus and installed from update. I have logged out out of Tidal and reset password. Resetting Tidal password worked for a few hours but next day same issue. I can access all Tidal albums on my phone. I am not sure what else I can do at this point.


@support I have tried everything today. Any help would be greatly appreciated. I did not have this problem until I installed 1.8 update. My first issue was not finding DAC but reboot fixed that issue. I have rebooted router, core, reset password. It will play tracks through Rood radio but when I search and select album i get message above…

Hey @Todd_Druhot,

Thanks so much for following up on your post - I’m sorry for the long wait. I’ve notified our technicians as well and you should hear back from one of them very soon.

Please, bear with us just a bit longer :pray:

1 Like

@support any update on getting some help with Tidal. I would contact Tidal for help but works fine on everything except Roon.

Hey @Todd_Druhot,

I wish we would have had an answer already - unfortunately, support is closed over the weekend, so today is the first day our technicians are replying to requests. You should hear back soon.

Thanks again :pray:

Hello @Todd_Druhot ,

Thanks for your patience here, can you please confirm if you are seeing the same behavior occur on multiple Roon Remotes or just one in particular?

Can you please let us know the exact local time + date + album you tried to open that has this error next? Once we have this info we can enable diagnostics mode for your account, thanks!

Changing the password in Tidal and logging out seems to have worked for the time being on the (unauthorized) but still have the metadata improver roon needs software update message.