Uninstalling ROCK

I have been trying for about 7 hours (off and on) to get Roon Rock deleted from my NUC.

I just download DBaN and it doesn’t work. It says: CAT Can’t open ‘/proc/cmdline’: No such file or directory.
But I see other people having issues with DBaN not necessarily related to Roon Rock. They download earlier versions. I am on my ragged edge of computer ability with this. I am done with DBaN.

I downloaded PartedMagic. https://www.majorgeeks.com/mg/getmirror/parted_magic,1.html

I burned the PartMagic ISO to thumb drive using Rufus. https://rufus.ie/

Now I have PartMagic on the desktop of the NUC but no idea how to get the M.2 drive in my NUC to be reformatted so that I can install Windows. My monitor keeps turning off repeatedly this entire time when I try to anything…so freaking annoying.

This entire process is the one most infuriating thing that I have ever encountered with Roon. This is BS.

I think that if Roon is going to give some much detail on getting Roon Rock setup there should be a VERY clear detailed section to explain exactly how to remove it from my HDD.

I admit I haven’t tried it on a ROCK NUC, but can’t you just use Microsoft’s Windows 10 Installation tool for this? Use the NUC’s BIOS to set the boot order to boot first from the USB stick holding the Windows 10 installation package.

On all the other systems I’ve used this tool on, it allows me to totally reformat drives before installing Windows 10.

1 Like

I have downloaded the Windows 10 ISO and put it on a thumb drive. Installed it on the drive using Rufus. The NUC keeps turning off the monitor every minute or so. I sometimes can get into the bios before it turns the screen off again. It will never start the Windows install. Nothing about the suggestions above mention anything other than vague suggestions.
As I sit now the NUC has brought the monitor back on by itself and takes me to a blank screen and goes nowhere.

What resolution is your monitor? It sounds as though it is below the minimum resolution that Intel requires for the GUI BIOS to display properly.

Why do you think there should be? ROCK is meant to create a Roon appliance. I expect that your microwave manufacturer does not provide a simple uninstall button or directions either. :slightly_smiling_face:


The iso is for installing in a VM. You need to get the windows 10 install tool from the Microsoft site. You need to go to the link from a computer capable of running the tool otherwise you end up at the iso page.


Yes this is the right way, the iso is for VM installs.

Show me a single OS that has this option…never ever have I heard of such a thing or even someone requesting it.

1 Like

You cant uninstall iOS either - just as an example. Just leave the bl**dy OS on there and done.

Geoff is correct, if you are running the install from the USB key you made with the MS Download Tool, that GED posted a link to, then, you will have the option to partition and/or manually remove existing partitions. There is, as Geoff also mentioned, an option there to tell the Windows Installer to just wipe the drive.

You can not uninstall ROCK. ROCK is not an “app” that gets installed or uninstalled. It is an operating system. What you are asking for is similar to buying a Windows PC and then saying “how do I uninstall Windows?” or buying a Mac and saying “how do I uninstall MacOS?”

You can not “uninstall” an operating system. You can only replace it with another (or with nothing).

1 Like

That is completely not the same thing…

It does nothing but reset the Roon in some way. I doesn’t make the HDD Roon is installed on go away or all the sudden the Windows is easy to install. It resets and in a moment Roon is just Roon sitting there ready to play. I did read the post and tried it multiple times.


but this is where I think you might find solace


I know you can’t uninstall an OS…poor choice of words at 12am in the morning. I don’t want the OS on there. They didn’t say warning, this is going to be a real hassle to every use this drive again for anything else.

The only thing that has been suggested that I haven’t done is I didn’t use the Windows 10 Install Tool. I am downloading that now. Hopefully that will be the issue.

You could purchase and install another M.2 drive.

That would have been the next step, buy another M.2 drive.

BUT using the Windows 10 Download Tool is what was needed at this point. That was after I figured out what the heck to do with PartedMagic. I wish I had done a few screen shots in PartedMagic…oh well too late now. You have to wipe the drive using it. I could not tell if it had been formatted at that point as everything I was trying was meeting resistance.

I think for me a USB to M.2 adapter cable would have made this easier as well. That way I could address the M.2 without extraneous issues.

Then I download Windows 10 Install Tool onto a thumb drive not using the ISO option but I think it is file option…just not the ISO. Thanks Ged!


It went perfect from there. But it sure seemed a tortured path getting something that seems so simple sorted out. I wish I had taken notes but this is what worked.

Good luck and thanks…

Getting off on the wrong foot can also screw up your head. :smirk:

Yep, stepping away from the battle for a while has amazing powers when you reengage! :blush:

1 Like