Update 17.2.23 crashes Roon on Mac and iOS

Roon Core Machine

ROCK on an intel NUC
Access via Mac desktop 10.15.7, iPad Pro and iPhone 10.

Networking Gear & Setup Details

Connected Audio Devices

Pi endpoints running Ropieee.

Number of Tracks in Library

Description of Issue

The last update I was prompted by Roon to install yesterday from the Mac has left me unable to open any of the Roon apps either on the Mac or iOS. It seems to be something to do with the connection to the ROCK server on the Intel NUC.

I can see and use the library on the nuc via ARC but on startup all of the front ends (Mac & iOS) to Roon crash.

I have tried re booting and reinstalling everything on the front ends with no joy.

I have tried turning the NUC off and then the roon app starts but as soon as it looks for the NUC it crashes.

Does anyone have an idea what my next steps are as I am fed up with listening to my library on my phone?


I have the same problem since the most recent update.
Hoping someone provides the solution soon…

I’ve the same issue on iPhone and iPad

Over here it looks like Roon isn’t connected to my NAS anymore. ALSO I was logged out and the tidal connection was gone. What went wrong ?!?

Hi all,

I’m just another user but I have seen some others on the forum with similar issues since this update, can you all check to see if all your remotes i.e phone, tablets, computers and core have been updated to the latest release?

Can you advise how we can check what version we are running if the remotes will not open the app? I personally have re installed the app on the IOS and Mac desktop remotes but can see no way of checking what version it is or whether it is in fact the latest

Have the same issue. Have tried restarting the Nucleus, force quit the remote app, uninstall and reinstall the remote app, nothing working yet. Anyone figured this out?

Can you acces the core WEB UI from your web browser:

You can see what build you are on under Roon Server Software and if it is not the latest build you can Reinstall the ROCK OS and I’m not certain but that should update the Roon Server software.

Same here. Very frustrating !

That require you to, from the instructions “open roon on any device” which is where the problem starts. We are all in the position that we cannot open roon on ANY device ! So therefore cannot access the settings pages.

What I can do is access and use the core using ARC which shows what version of ARC is being used. So it is not the case that the core is not working.

I don’t think you understand, the page I showed is the WEB UI of your ROCK core, it’s accessible from any web browser connected to your home network.

It has nothing to do with Roon’s settings page and you don’t need Roon to view it.

I’ll bow out now, until @support comes along.

can you just gp through the steps that I need to do to get to that please. and thanks for putting up with a twit here !

I sure can and you are most definitely not a twit!

You will need to find the IP address of your NUC Core that runs ROCK or failing that you can type this into Safari’s search bar http://rock.local.

Hopefully it should then load and look similar to the one I posted above. If your RoonServer build is already up to date, then I think you will have to wait until Roon support chime in on this thread or try re-installing Roon OS from the web page.

Genius …

Trevor, I don’t think this issue has anything to do with your ROCK/NUC - there are reports elsewhere in the forum that this is like more to do with security updates recently released by Apple for iOS and MacOS. The Support team are aware and investigating.


interestingly it shows 100% of the database available which is probably not a good thing

It’s fine - you have a large SSD, and the database is probably less than 1% of that

Thanks. I will hang in here with ARC and my airbuds and dust off the valve amp when this is all sorted.

You might still want to update your core, build 1143 is way behind. Even if it doesn’t cure the issue.

1 Like

Well spotted - and a good point.

1 Like