Update to Roon 1.8 Build 880 corrupts my Roon Core database

Very strange, but as of late last night I have been able to sign into my account and restart access to my Roon app, core, database. As I saved a Roon folder as _old I was able to remove the newly installed Roon, drop the _old from the older version, and update it to 882. Wow. I am listening to the King FM Christmas channel as I type. Whole family is happy again. Thanks Roon for whatever is fixed.

2 Likes

Thanks for sharing and for the motivational boost the team surely needs now.

1 Like

I am using the sync backup tool to replicate my Music files between my Master Music folder on my PC, my Roon music folder on ROCK and a backup folder on my QNAP NAS. I do not use it to backup my Roon database on my ROCK - to do that I only use the built-in Roon Backup tool, and backup the database to two different locations (separate SSD on ROCK, where I also keep local music, and a Roon folder on QNAP NAS).

I also use it to replicate all my OneDrive and Local PC data (Documents, Pictures, Music, and Video etc) to separate storage drives and NAS, so that if I have to rebuild my PC, or Microsoft loose all my OneDrive data (it does happen) I can restore.

My reply was to Michael, who raised the possibility of using a sync tool on the database… :grinning:

OK, but as he was replying to me, I thought it was a comment to us all… plus it clarified for others…

@Geoff_Coupe agree with you completely. I was referring to backing up the Roonbackup directory (i.e. backing up the backup files). By I wouldn’t recommend doing either. II believe that you trust the Roon backups and/or consider using a tool that will do an image copy of your Roon boot disk.

I do like FreeFIleSync as solid, free backup tool for the actual music files and use it all the time to backup all my directories of album music files (mostly flac).

Hi,
I had the same problem on version 882, solved after reinitialization of database, deleting the RoonServer folder as I was stucked with the corrupted database message.

Thanks for the update and support, but It doesn’t look like a serious solution after this critical issue for a paid product.

@ y’all Don’t y’all know by now it is NOT ROON ever — it’s YOUR system— just read comments by AudioDoctor and many others including the founder Chris on Audiophile Style IMHO the axiom is KISS :kiss:—- I now use Audirvāna Studio almost never a problem but if I do AS support always fixes it and in one extreme case even took over my computer from France and fixed it— ROON ever done that for any of us?? Lifetime subscription like me?? Don’t think so

1 Like

You might want to read the following comment from Danny:

Short version “Correct. Backing up a corrupt database is wrong and we should neve have done it, and we don’t do it anymore.”

Yes, good point. If you cannot deal with backups, give us a workaround.

1 Like

Just adding my name to the growing list of users who are having problems with a corrupt database.

I did an uninstall and completely fresh install of Roon. Worked fine after redoing all my settings. Closed Roon. Opened Roon and immediately I got the corrupt database error. - even though my database was brand new from a brand new install.

I’ve gone back to JRiver for the time being until this Roon issue is fixed. Connect to my SOtM sMS-200 rendered (which is connected to my DAC) by enabling DLNA on both the sMS-200 and JRiver.

I feel sorry for the support team, developers and testers at Roon. You’re probably under a lot of pressure right now - just before Christmas. Good luck.

2 Likes

Did you update to Build 882?

So rather frustratingly I’m going back around the corrupt database buoy. I had the hassle of a corrupt database with the upgrade to B880 a few days ago but got things back on track by restoring a backup for a couple of months ago. It’s worked perfectly for the past 4 or 5 days but on trying to open up Roon this morning I’m presented with the corrupt database message as it seems to have updated to B882. So a database that worked perfectly well on 880 for a number of days is now unusably corrupt on 882 - and advice from support staff as to why? What changed between 880 and 882 that makes the database useable on one but not the other?

Hi @mike @danny @enno @brian Any update here? Logs were requested and submitted a number of days ago.

I now have expended about 2 days of my time, so far, in updating my fresh B880/882 database to try and get this in the same position of my B831 version prior to this update. I would like to understand your approach and compensation offer to those affected by this failed product update.

There hasn’t been updates from Roon on recovery methods, methods of exporting details from an now un-usable scheduled B831 Backup taken by the Roon Core. So I am only assume that it is deemed an acceptable approach with just “you will have to build a new database, starting a fresh” as communicated in the response by Rebeka to the ticket submitted concerning this issue, as it happened.

When you introduced a database check in the 880 release which would cause a hard halt of the product, did someone not care to think “What happens when this occurs?”, “What can do we for customers who finds themselves in this position, where their Roon system has suddenly halted, following the update” and “What do we say to those customers to whom this happens”, “Should we be introducing this check in this release, the week before Christmas, when we have no recovery tools, no plan for customers to whom this happens to with the potential that we could leave some customers with a non-working Roon system until they take drastic action to throw everything away and start building their library again?

1 Like

So I’m back up and running again on B882 having restored from the same earlier backup which worked on B880. It will be interesting to see what happens on the next update…

2 Likes

Yes 882. Will do a clean install again this evening and report back.

I work in the software industry and this announcement by Roon is really bad. I was cringing the whole time reading it:

But this was the worst: “In our investigation, we’ve found no evidence that this release causes data corruption, or is in any way worse with respect to this topic than previous releases”

Absolute BS! I totally uninstalled Roon and then installed the new version. Shut down Roon, attempted to restart it - and boom Roon had already corrupted my shiny new database.

Trying to blame the users (some on here who are obviously “power” users), networking, hard drives, bad RAM (lol), etc just takes it to the next level. And then of course along come the fanboys supporting Roon in all of this, who are adding absolutely nothing for the people who are working to try and solve this problem.

My bet is it has something to do with this: “It’s not uncommon for us to reorganize the Roon database”. They reorganized the internal database tables, relationships and structures. But, on top of this they probably have a coding layer (C#, Java, whatever). The coding layer wasn’t updated properly, so when the “old” code went looking for the “old” database structure instead it came across the “new” database structure and kaboom! And of course their marketing/business department say we can’t admit that, let’s blame the end users! Friggin shameful.

The truth will come out. Developers/testers don’t tend to stay with the same company forever…

6 Likes

Yeah good points. The Knights of Roon have proved they are up to protecting the Majesty.

As I was challenged on another forum to a fight (I don’t enjoy getting punched in the face)

I want to be clear as day- there are very helpful and kind people on this forum. People who take time out of their day as Roon Staff go missing in action routinely.

And there are more who just bash you and defend roon when you have a problem.

Not sure where it all comes from. We’re all here cause we love music. And we all like roon to varying degrees. Why can’t we all get along? Lol.

Roon does not seem to make mistakes and it’s supporters shout down the community members who need help the most. Roon has became a football team with its contemp for the opposition.

6 Likes

Hi all, I noticed that this thread has turned into a mix of:

  1. Confirmations that everything is ok after Build 882 :tada:
  2. General feedback about the release
  3. Continued trouble even after updating to Build 882

For #2, please use the main feedback thread. You may not get a response from us, but I promise you that we’re reading!

For those of you in group #3, I’m going to close this thread and split your posts into new threads/PMs so we can have a look on a case-by-case basis. Some of you are experiencing actual corruption that we won’t be able to help with now or in the future, but we’ll follow up with you to find out.

Thanks!

1 Like