Update to Roon 1.8 Build 880 corrupts my Roon Core database

:mega: Staff Note :mega:

Original Post:

Roon Core Machine


Running on an Intel NUC5i3MYHE

Networking Gear & Setup Details


Connected Audio Devices

A number of devices, including SonoreUPnP Bridge to Naim NDS, Chromecast Audio

Number of Tracks in Library

97k tracks

Description of Issue

Following the application of the latest Roon release B880, my Roon Core database becomes corrupt

I have tried the following, so far:

  • Rebooting the core (ROCK)
  • Reinstalling ROCK on the Core
  • Restoring a previous Backup - here the Backup restores, and the update is applied, in that the new Build updates the database, and then crashes as the Database has become corrupt.
  • Tried installing an earlier Backup, and the same process occurs (Restore successful, new Roon release updates the database, Roon Core database becomes corrupt).
  • Tried renaming the RoonServer folder to RoonServer_old in the ROCK database location (to force the Roon Core to build a new Database), reconnect to the new Roon Core instance and then restore a Backup to it. But the Database update process from the new Roon Build still corrupts the Roon Core database, with the same message.

In addition one Windows (Win10) based Remote no-longer connects to the Roon Core.

Prior to B880 update all was running well for the last number of years.
Have been using this NUC as ROCK server since ROCK was released.
@support @kevin @mike So I am DOA following this new release

Update on this issue - have just swapped out existing NUC for a spare one (same spec NUC5i3 with 8GB RAM and 240GB m.SATA SSD) - also installed with ROCK and an earlier version of Roon Core (probably from a restored back up from 2020). This initially updated to B880 and picked up from the previous state (finding new library additions etc) however the new Update (B880) then applied its database update, and the database has become corrupt).
So this isn’t a hardware issue, but something that the database update relating to B880 is doing to a database running on a previous build, that is causing the corruption.

Hi @support Update on my issue

  • none of my Backups restore and operate, all suffer Database corruption shutdown with B880

  • my Backup ROCK server with a Roon Core from over a year ago does not operates, also suffering shutdown due to database corruption

As I understand what is being presented as the solution, is to rebuild the Roon Core database from afresh.

It is the week before Christmas, I have nearly 100k tracks in my library that were well organised, Playlists built, representing a significant investment of time since starting using Roon back in 2015. The database I am replacing is there since Build 30, the last time I experienced an issue and had to rebuild. That was a very different library.
I am not sure whether the scanning & indexing of my library will be complete by next Friday 24th, leaving me without Roon for all of next, the run up to Christmas, Christmas Eve, Christmas Day, St. Stephens Day/Boxing Day. Now I know Christmas is not a big deal in the US, but in other parts of the world it is. Just imagine your Thanksgiving celebrations without your Roon system!


+1 I got the same issue, and have a similar setup (ROCK on NUC). Backup restores Database, but it becomes corrupt after a short while.


Same as mine , I have ROCK on NUC and has the same issue, I cannot restore to previous database. (When restored complete, it collapse again and again). So dissapointed! I lost my playlists, track loves, album tag, etc. I am so sad. :frowning: No solution yet!


I have the same problem but running my core on a Mac Mini 2012 with Catalina. It would seem like this “data base update” is corrupting everyone’s database regardless of the OS we’re using.

I’m lucky to have Plex running as well. At least I can listen to music while this gets sorted out in Roon.

1 Like

I’m having the same issue with a windows 7 Roon Server
Tried restoring the DB and create a new one from scratch, when syncing Tidal libray y gets corrupt too

Hey @simon_pepper,

We want to thank you for not only reporting this as soon as it happened, but for having tried so many troubleshooting steps already.

This makes it even harder to copy here the post that will answer your questions. Please know we’d all wish we had a different solution:

CC: @Marten_Leijon, @Thanavit_Chaiyapa, @Manuel_Alejandro_Lop, @Daniel_Inhetvin. It is very likely that it’s the same issue in your case as well. Not only are we extremely sorry that this is happening, but we also feel with you — we (the Roon team) are experiencing the exact same thing as you and some of us are starting fresh… :pensive:

Not really a solution.

Could I ask that you provide a special version without the database checking, as a temporary version to allow those users affected to export Playlists, endpoint settings and other system settings, to facilitate the creation of a new database in Build 880.
Alternatively, allow a regression back to Build 831 to allow the user to export settings and Playlists.
This would take some of the pain away.

BTW This is the second time in having to start a Roon database from afresh, since the initial Beta release. Last time was with Build 30 back in 2015.


Starting fresh also causes the corruption to appear. so there isn’t anywhere to go?


The Roon team’s position seems too passive. Instead of trying to solve users’ problems, they suggest that they start over. Maybe it’s better to develop a new version that will detect and fix errors, even with partial data loss, instead of completely blocking the program?


This could mean that you’ve got Roon running on an old PC with an unsupported OS, your harddrive is nearly full, or the harddrive is just completely shot.

Can you tell us more about your PC? HDD or SSD, and how old is it?

Couldn’t agree more, I’d be gutted if all the work I did (particularly on tabs) was lost.

Rather incongruously I see this to my right as I type.

If this is problem “solving” I’ve obviously always misunderstood the concept.



If anyone has actually worked around the corruption issue by successfully restoring an old backup, please post here. Until and unless someone reports success with that strategy, that recommendation isn’t even worth attempting.


Does the local database engine used not have a repair utility? Might lose/orphan some objects, but salvage the 99% that is intact?


I have gone back to a Roon Core on my backup ROCK (on a NUC) server that was over 12-months old and the Database update and latest release still causes Roon Core to crap out. So, for me, restoring a Backup from beginning of November is not going to solve this.

For me, the problem is the Playlists & the system settings - I need a way of getting those off a backup image, and then be able to apply them to a fresh database.
The previous database represented just over 6 years of Roon activity.


Nope - Roon just craps out

1 Like

Same here, i tried 3 different Win10 machines. One is a brandnew Dell unit. When i set up a new database i do have the same problems with it after a restart of roon. On all 3 devices. Please check it by yourself . The problem occurs when the Database is bigger than 3 GB. I restarted a few times while building the new base. Everything was fine until it was bigger than 3 gb. Hope that helps… Good luck .

Interesting - I would hope that the release would of been tested on users with Roon Core databases larger than 3GB.
According to the x% of total storage available, mine is some 20GB
Plus it dated from 2015, i.e. had history of tracks added, artists/albums played for the last 6-years - such a shame to lose all that.

When you set up a new database do you see “there was an issue loading your database”, or does the application start and you have no audio devices?

To be clear, these are the steps you need to take to start fresh:

  • Close Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

Let me know what you see after that?

1 Like

Exactly the same problem here running ROCK on a NUC and tried same steps as the OP.

Suggesting that we just start completely from scratch is NOT an acceptable solution befitting of an expensive high end product!


“there was an issue loading your database”…
I did everything, renaming, new setup etc. When I restart after the base reached a bigger size, i do get the error. Meanwhile i am using a database build with no local files, online with tidal. Works good, the database is 900 MB…