UPnP Autop Forwarding Issue on Virgin Router (ref#3PYWTI)

What’s happening?

· I'm having trouble with Roon ARC

What best describes your issue with ARC

· Other

Describe the issue

Roon config has enabled UPnP to created Auto port forwarding on my Virgin router - port 55002. Roon server says "Your Roon ser

Describe your network setup

Port Forwarding was auto configured and has been confirmed to be securely accessed by Roon ARC. However on the iPhone, I can see Roon ARC working great - so long as I am on same WifI network on the same network as the Roon Server. Once I switched to data network, on iPhone I get the red dot on the Roon Server "port Forwarding Issue" So the error seems to be comms from iPhone to server, via data network. Virgin Media Hub 5, Silent Angel Network switch.

Firstly, there is no need to obfuscate the ip address of your Roon Server. Thus ip address will be an address on your local network and does not present a security issue because is non-rouable. Hiding local network ip-addresses can, in some circumstances, make diagnosing an issue more difficult. This applies to any ip-address starting with:

  • 192.168.
  • 172.x. where x is in the range 16 to 31

By contrast, the WAN side ip address of your router (as issued by your ISP) should be kept hidden.

With regard to your port forwarding issue, can you post a screen shot of the Roon ARC settings page in an ordinary Roon client (desktop or phone/tablet)?

You say ARC is working on your local network (phone on hkme WiFi). This is expected and basically confirms that you local network configuration is good (or at least good enough).

Probably not relevant but I am assuming a wired connection between the VM hub and the switch and again between the switch and your Roon Server with the WiFi being supplied by the VM hub (no mesh WiFi systems in use).

Everything hard wired, with Cat8 cabling, no Mesh.

OK. Thankyou. It certainly looks like everything is OK from the Roon Server and Router end of the connection.

What happens if you logout in ARC and then log back in? Are both your Roon Server and Roon ARC on your iPhone up to date? As of now, Roon Server should be on build 1432 and Roon ARC should be 1.0.53 (Build 100272)

If you can’t get Roon ARC working any other way, you can also try using Tailscale to bypass the need for port forwarding:

The use of Tailscale effectively means that ARC is accessing the Roon Server as if the mobile is connected to the same local network as the Roon Server - which you have already said is already working.

Hi @john_Grundy,

Thank you for your post.

We’ve activated ARC diagnostics to identify the failure. Here’s what we’ve found:

  1. First, certain ARC services negotiated by RoonServer are failing because they can’t reach the upstream server in time. Do you have any security services or managed network software that might be filtering RoonServer’s connection? This isn’t the cause of the issue, but it’s likely exacerbating the problem.

  2. On the ARC side, there are session authorization failures due to cached associations with previous RoonServer instances or port assignments. Have you reinstalled the app since switching between RoonServer machines, by chance? It’s a heavy-handed step, but I’d start there.

  1. Not that I know of just a standard Mac build, nothing special on iPhone.
  2. Yes I tried deleting and reinstalling, both the Roonserver and the iOS ARC app. then resync on WiFi. On data network no access

I now have it working with Tailscale.

Thank you

I wonder what’s stopping this normally? Virgin Media ISP?

It worked for one song, now I get this error…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.