Upsampling not allowing 256

I have used Roon upsampling for a few years. I upsample to 256 with Roon on my SonicTransporter I9
The I9 feeds to an UltraRendu and they sent via USB to my Playback Designs IStream and MPS-5 DAC section.

This has worked fine for a few years. Today I went to listen and the displays on the Playback Designs equipment showed 44.1 not 4 X DSD as usual.
I went to Roon and to the volume icon and selected DSP. I tried to reset the defaults to 256 but the choice only goes up to 128.
Can someone tell me what settings are incorrect that it is preventing me from going back to 256.


Power it all down and back up. It should just be a glitch.

Thanks Henry
I have tried that 3 times and it still only will allow 128.
I clearly am missing something but I’m at a loss.

Have you checked the advanced tab in device settings in Roon for your endpoints?
Make sure the max rates are correct for your devices.

Can you tell me which advanced tab specifically and how to find it.
There is one advanced selection a ran across but when I selected it nothing happened. Just old person memory.

Click the volume icon then the cog icon.
This will bring up device setup icon.
Click that and you’ll see an advanced tab

Thanks Jeff, this time the advance tab did open but it will still only let me choose a max of 128 for DSD. Could the PCM settings have anything to do with this?

Is it possible to restart just the Roon program that is in my Small Green Computer / SonicTransporter?

I’m not with Roon, just a fellow user.
That was the only thing I could think of.
Another user or someone from support will be better able to help.

1 Like

You might want to repost this in the support thread as someone from Roon might be more likely to respond there.

Thanks Jeff I will try that.

1 Like

DSD playback cannot do DSP with native resolution. So, it will drop down to DoP Dsd, meaning if you DAC does 256 native, it can only do 128 DoP.

DSP includes volume leveling.

Thanks Rugby, My DAC has, as I said done 256. I obviously set it up incorrectly.
Can you tell me or direct me to directions as to how to set it up to be able to do 256 again.

Thanks Brad

Can you show what you see in Roon please (settings for the device and also the signal path when playing)?

Device settings/configuration choices in Roon for the most part reflect/are limited by capabilities reported by the devices themselves (or inherent limitations of the transport protocol used). So you may want to check the settings on your streamer (UltraRendu) too.

I was unable to find information on either of the two devices – so please check their settings too if available and applicable.

Additionally you can ask for support by the device manufacturers:

  • For support on Small Green Computer products go to and press contact us. You can submit a support ticket.

  • For Playback Designs see here.

Just remembered from the time spent with my MicroRendu that there is also a maximum resolution setting there. I’m pretty sure you have to check that, and updates to that device can reset some settings.

I was able to get it back working with all your help and Andrew from SGC.

It was going into the UltraRendu and having it run diagnostics on the DAC that made it locate it again and I was able to reset the DSD defaults.

Ironically within 5 minutes of getting everything smoothed out one of my monster tube amps decided to do a run away over heat. Definitely lost tubes and resistors.

I have been waiting to be able to get them to an EE friend that is going to convert them from 6550 tubes to KT120 and lower the bias and internal heat. Oh well time to call the moving company to start the process. It seems to be the nature of audio, fix one thing and something else raises it head for attention. :face_with_symbols_over_mouth:

The KT120 is a lovely valve. Good luck.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.