uRendu with Oppo Sonica and DSD

Hi Jesus @Jesus_Rodriguez

I’m borrowing a uR for a couple of weeks…just to see how it goes in my system. But I’m Struggling with some dropouts at DSD256 (DoP) and can’t get my DAC to work at all in DSD Native. Note the Oppo runs fine at DSD512 NATIVE on my RPi with Ropieee. LAN is 1Gbps connection

here is the DAC output

  1. USB Audio Class Digital alsa audio output interface `hw:0,0’
    • device name = OPPO Sonica DAC USB AUDIO 2.0 D
    • interface name = USB Audio
    • usb audio class = 2 - isochronous asynchronous
    • USB ID = /proc/asound/card0/usbid
    • character device = /dev/snd/pcmC0D0p
    • encoding formats = S32_LE, SPECIAL
    • monitor file = /proc/asound/card0/pcm0p/sub0/hw_params
    • stream file = /proc/asound/card0/stream0

Home page shows

Version: 2.3
Model: microRendu
IP Address:
MAC: D0:63:B4:00:CF:6E

Could this be a performance limitation and or version/kernel issue - or a combination of both?
playing at DSD128 seems to be OK as DoP

@wizardofoz You are on 2.3, might be worth updating to 2.6, go to the Website click on find my device then manage then apps.

SonicOrbiter 2.3 > 2.5+ is not a downloadable update, but must be ordered on a new SD card via Sonore. $20 incl. shipping, if memory serves me well.

OK I did that but got this… and unit still says 2.3

Upgrade in progress…

06/01/2018 19:43:39 - Starting upgrade. (This can take a long time…)

06/01/2018 19:43:39 - Updating sonicorbiter packages…
Last metadata expiration check performed 0:00:01 ago on Fri Jun 1 19:43:43 2018.
Dependencies resolved.
Nothing to do.
06/01/2018 19:43:45 - Updating process 1 of 3 complete…
06/01/2018 19:43:56 - Updating process 2 of 3 complete…
06/01/2018 19:43:56 - Updating OS packages…
Last metadata expiration check performed 0:00:05 ago on Fri Jun 1 19:43:52 2018.
Dependencies resolved.
Nothing to do.
06/01/2018 19:43:58 - Updating process 3 of 3 complete. Please reboot


I believe you are correct, my apologies, my Microrendu came with 2.5 when I purchased it.

Ok so this a limitation of 2.3 then? I can flash a card but I wonder if I can get an image file in the interim. I don’t mind a small charge but paying to get a new SD and shipping seems odd in this day and age for a software update.

Question for @Jesus_Rodriguez I guess? Interestingly I compared my Microrendu and Allo USbridge into my Holo Spring L3 dac via a Matrix Audio X-spdif 2 and heard no difference, in fact the only difference I noted was the Allo got nowhere near as hot as the Microrendu.

1 Like

It’s not a trivial update to go from 2.3 to 2.5/2.6 so we decided to offer a uSD card. It’s also not a DIY project so we don’t treat it like one. Anyway, the regular updates are done over the internet.

@Jesus_Rodriguez but that doesn’t really answer the question of is this causing the issue for this dac and bitrate. No point I upgrade even if it’s free unless that’s the fix for this issue.

Recall that this is not my own unit and that I am trying it out only.

Have you gone into the Roon settings via sonicOrbiter.com and changed DoP to Native DSD?

That’s not a v2.5 feature - Native DSD has been fine with v2.3 also.

I’m not using sonic orbiter I’m using rock or windows and yes I’ve tried native DSD in the uR interface and get nothing at all…only DoP works up to 128 and I’m using DSP in Roon not hqp. If I set native in the uR interface there is no DSD option in DSP to use at all.

sonicOrbiter OS is the OS of the Rendu…

Ok cool. After enabling Native DSD in sonicOrbiter OS, sometimes I’ve then needed to reboot both the Rendu and RoonServer for native DSD to show as an option in Roon. I’m guessing you’ve tried to reboot both already.

Strange one.

Well I’m going to try on my other Soekris R2R dac and see if that might be any better or my other OPPO HA-1 or 2 that do DSD256

But maybe this little box of tricks is not for my setup…I’m just trying to do some A/B testing to see what all the fuss is about with these kinds of devices…it’s connected to an Uptone UltraCap power supply too.

I had my Rendu working fine with a HA-1 in Native DSD256 - no dramas. Sonore are up there as quickest with patches to sonicOrbiter OS, so it’s a strange one.

Unless the Sonica Native DSD patch is different to the HA-1 and only available with v2.5 ? I would guess unlikely but you never know.

Hope you can get it sorted. And let us know how the HA-1 goes.

Well at least the HA-1 is seen with DSD Native selection available in the DSP settings and DSD Native in the uR setting…but in DoP I can only get the DSD128 option.

Playing now in Native DSD 256 and seeing if I get any dropouts.

1 Like

Per the HA-1 specs: “DSD256, native mode only”

The Oppo Sonica needs Sonicorbiter 2.5/2.6 on the Rendu for native DSD support.


So if I order on your website which one do you send? Doesn’t seem to be an option for what version…only UltraR or uR. The one I need is microRendu

Roughly how long will it take to reach me in Singapore? @Jesus_Rodriguez

Can’t answer the last question, but all new orders from Sonore have been shipping with 2.5+ since it was released.

The ‘order an SD-card’ upgrade was introduced to facilitate an easy path for a large and complex upgrade, not to charge for the update itself.

We ship SD cards with 2.6.