USB HID control

Hi Harry
it would be awesome if we could use USB HID protocol to play/pause playback from ropieee when using a USB DAC that has IR and supports its. My irDAC ii does. Not sure how difficult this would be somebody else is looking into it but I think for a mac server not an endpoint.

1 Like

Hi @CrystalGipsy,

That’s interesting. In general I would say that this should not be that difficult with RoPieee, as there’s already a remote extension to handle commands from the touchscreen.

What I’ve read is that different devices have different mappings, so I think (I’m speculating here :wink: ) that it requires a device specific mapping.

Biggest problem? I don’t have a device like that.

I can test it for you. Perhaps a part of the webpage to assign the mappings?

Well, I first need to figure out how it exactly could work. But I might be able to test this with a simple keyboard to get the basics working and then we need to find the mapping for your DAC.

1 Like

Any news on that? I really would appreciate to be able to use my Pro-Ject Pre Box S2 Digital with ropieee and to be able to use the remote properly. Tnx!

Any updates on getting HID media control support into RoPiee? I have an Oppo HA-1 connected via USB and the infrared remote that comes with the unit does not work. I switched to RoPiee to get native DSD256 working, since that doesn’t work via a Macbook Pro, so now I have to choose whether to lose DSD256 or remote control…

Implementing HID should also allow plugging in an external keyboard with media controls, no?

@Tomi_Blinnikka assume you have tried to replace the battery in the HA-1 remote.

Thanks for the reply. That isn’t the issue. I literally just unplugged the HA-1 from my Mac (where remote works) and plugged into the Raspberry Pi. Also, the mute button, volume, etc. non-media controls that go directly to Oppo, work.


Biggest issue for me is that I don’t have such a device. And just trying stuff by ‘trial and error’ is not much fun.

Have you tried with a USB keyboard that has media controls? Or is there anything I can try to help with?

I’m running RoPieee on a Raspberry Pi 4 - works great and recognizes my several USB DACs. I just connected a HiBy FD1 DAC/Amp - realized the FD1’s flat, square shape fits perfectly on top of my Pi’s Geekworm fan-less case. Like an external HAT! I was excited because the FD1 has hardware control buttons. The volume buttons work, but the play/pause does not. Bummer. Is this the same issue others on this thread were talking about? I tried the FD1’s switch that changes it from USB 1.0 to 2.0, but that did not change things. The FD1 is only $59. If this is still an outstanding issue just waiting for the developer to have test hardware, I’d be happy to donate this FD1 to the cause, or buy a new one and ship it to you. If that would help.

1 Like