Using any audio source with HQPlayer - Spotify, Amazon, Apple Music, YouTube Music, Deezer, Soundcloud

Since the syntax highlighting shows the entire row as blue, instead like the other lines, there’s some issue with some characters there or something else. If the format gets corrupted, HQPlayer fails to load it and the web interface is not responding anymore until this is fixed.

1 Like

@dabassgoesboomboom So my initial attempt to get Apple Music streaming using the UP board input has failed. Everything looks correct in the HQP OS settings: correct INPUT setting being the UP board and my NAA output to my headphones. Tested streaming Apple Music from the Bluesound Node input to the HQP OS server to the NAA and that works perfectly. So I know the audio path is good. But when I plug my iPad into the USB cable into the UP OTG I get no audio when I start an AM stream on the iPad. The HQP OS log seems to indicate the input is switching properly. Just no audio. Here’s the log…

CleanShot 2022-03-11 at 10.42.46

Any thoughts from you or @jussi_laako on why this might be?

Still do not have an Upboard by myself. Did you try with another cable, Michael? Do you use CCK for the connection? “But when I plug my iPad into the USB cable into the UP OTG I get no audio when I start an AM stream on the iPad.” + Well, I guess you mandatory need CCK please.

I bought a USB OTG cable specifically for this use case. I am NOT using the CCK adaptor since I have another Apple-branded USB-C adaptor that has USB-A, HDMI, and USB-C pass through. Do I need to specifically have the CCK adaptor for this to work @dabassgoesboomboom ? I thought any adaptor than went USB-C to USB-A would work.

Are you using this one at iPad Pro? USB‑C Digital AV Multiport Adapter - Apple (DE)

rooUPnP: Finally a Roon Extension for UPnP Streamers ++ Once you make it to Roon, you are in HQP as well. Did not try myself but this opens e.g. BubbleUPnP universe if I am not wrong…

Just to make sure we’re talking about the same thing, you are using the adaptor Michael has linked above?

If so, that should work. I use it too.

This audio path is not using UpBoard is it? It’s using miniDSP USBStreamer?

As is usually the case with troubleshooting over the web, can you include more screenshots, especially when you have activated UP-input

  1. ‘Main’ web screen

  2. Config web screen. Full screen , not part of it

  3. iPad audio output screen. With music playing of course. You need to tap Airplay button and then show what shows for audio output.

The more that I can see, the more I can help. I’ve been through every struggle possible but I need to see what you see

1 Like

Yes. I am using the same adaptor he has linked to.

The audio path that works is using Airplay to the Node–>USBStreamer—>HQP OS—>NUC NAA. The UP board is not in the path. I then switch the INPUT from the USBStreamer to the UP Board, plug in the USB-C adaptor to the iPad via OTG to the UP Board. I see in the log that the input has been switched - posted that earlier - but no audio when I start a song in AM. Screenshots below…

@dabassgoesboomboom Also just confirming that I was supposed to change the OTG in the BIOS of the UP Board to ‘DEVICE MODE’ as per @jussi_laako posting this somewhere in another thread. Correct?

You don’t need OTG cable. You need just ordinary USB A → micro-B cable.

I assume Michael means the Tripp Lite cable I linked.

I might have referred to that Up Gateway port as OTG port, so that might be what he means?

I have that 2m cable.

@Michael_Grant This is what you should see below. ‘Playback inactive’ is the output you want. I know that sounds counter-intuitive (everyone is probably shaking their heads reading this) but just trust me :grinning:

Leave the music playing, take out the adapter from iPad and re-plug it in.

Report what happens.

Keep your speakers/headphones volume low during all these preliminary steps

I’m using all the same things you have. Same cable, same Apple adaptor, same UpBoard.

Everything else looked good to me in screenshots

Yes correct, I have this below saved in my notes.

I don’t remember all this stuff. Once you have it working, it is very much ‘set and forget’.

@dabassgoesboomboom OMG it works now!!! I changed nothing EXCEPT unplugging the iPad adapter and then doing what you said: start the music, plug in the adapter, and I then saw the RME levels come to life. I did notice that I had initially set my iPad volume all the way off. So I raised that. I also did see the little blue indicator show up in the upper right of the iPad once I plugged the adapter in. BUT…

I just tried to repeat this but this time I unplugged the adapter and then plugged it back in and THEN started the music. Nothing. And no blue indicator. Now it seems flakey. Sometimes I see the blue indicator for a few seconds and then It disappears. Ugh. Getting closer but seems like it should just work at this point with the adapter. Note I am running the iPad OS Beta 15.4. But not thinking that should matter. I will keep playing with this but early indications are that this is not just plug and play at this point.

1 Like

I don’t have the patience to be fluffing about each day with this stuff. It has to be set and forget for me, or I wouldn’t be using it. I can get Apple Music playing through HQPlayer faster than Roon these days… Roon takes longer to boot up than Apple Music.

When this is working properly, you can’t actually raise or lower iPad volume at all, so not sure what you mean.

Check out my post above about BIOS settings. Maybe you typed while I typed. It’s not just Device Mode that you need to check…

Like I mentioned, it took me a year to reach this point.

You are lucky to have help to faster progress :wink:

1 Like

Played around with it further and have never been able to get it to work again after that very first time of plugging it in while music playing. I switched out my OTG cable for a micro-b cable on the off chance there was a cabling issue with that specific OTG. But nope. Still doesn’t work.

What happens now is that when I plug in the USB adapter to the iPad I get the little blue USB adapter icon in the upper left part of the screen for a few seconds but then the audio never switches to the new output like it did the first time I tried. Very strange. It’s like it is trying to register the USB-C output but it doesn’t stick and it appears that the audio stream is never sent out through the USB C port. I tried switching from my iPad Pro to my iPad mini 6 and both had the same issue. But both are running the 15.4 beta so if its a software issue then that would explain seeing it on both devices.

I’m out of ideas until Apple releases 15.4 next week. But I am running the release candidate I’m pretty sure so not much hope that that is the issue. How frustrating to get this close.

I did confirm that the BIOS settings on the UP are correct. Dead in the water.

@Michael_Grant Tried to reboot the iPad?

Also try to plug it into Mac. Mac audio can be routed through HQPlayer the same way.

‘Playback inactive’ should appear as a soundcard.

Windows PC too.

What should I see when I connect the USB cable to my Mac? Should it show up in the Sound preference as an output? I just plugged the OTG cable into my Mac and am seeing nothing in the Sound pref panel.

As I just wrote above, a soundcard called ‘Playback inactive’. Just like the iPad.

Below example. Remember HQPlayer and even the UpBoard itself, hasn’t got a clue if the USB source is an iPad, Mac, PC.

You might need to go to ‘Input’ and reselect UP-input.

@dabassgoesboomboom Okay, never mind the last post. I plugged in the same adapter and it showed up as Playback Inactive as you say. And the Mac is streaming Apple Music to the RME just fine!

So this tells me that the iPads with 15.4 beta OS are the issue! That’s good and bad. But good as your setup works!!!

Now I just need to figure out the iPad issue and we’ll be golden! I will try rebooting the iPad and try again.