Using Audioquest Dragonfly as an endpoint

(Tom Russell) #1

I have an Audioquest Dragonfly DAC headphone amp USB converter that I would like to use in a different room to use for casual headphone listening.My core is on a server on my network using Roon. Would I be able to use the Draonfly USB. Could I connect the Dragonfly to the USB port on my router and would ROON see it as an endpoint?

(Jeff) #2

The dragonfly would need to be plugged into something capable of being a roon endpoint. A router isn’t a supported endpoint.

A computer, android device, raspberry pie etc are.

#3

Hi,

My first post!

I have a similar question.

I’m planning to use an Intel NUC as the Roon core with a USB hard drive containing the music.

So could I connect my Audioquest Dragonfly Red into the NUC and then the Dragonfly into an amplifier?

Thanks

Paul

#4

To the topic starter: no this won’t work as @DrTones describes. The device the Dragonfly is plugged into needs to be either “roon ready” or have a version of Roon installed onto it by you.

@PaulCS yes this works.

This page shows you which functions each version of the software enables:
https://roonlabs.com/downloads.html

On the bottom you see that ROCK supports output. A Dragonfly Red doesn’t need drivers, and is known to work on Linux (which the ROCK is in a modified form). I own a DF Red but don’t have a NUC I can test it one to be 100% sure. The theory suggests it should work.

Also, if you get a “H” version (the slightly taller ones) of a NUC, you can also drop a media harddrive into the enclosure itself, should you wish to do that. The drive needs to be the smaller laptop sized version, and the OS would need to go on a separate M.2 SSD you click into the NUC’s motherboard. I’d prefer that over an extra cable and enclosure for a stationary system.

And indeed, get a cable with a 3,5mm jack on one end that goes into the DF Red, and whatever your amp or active speakers takes as analog in (likely RCA).

Good luck!

(Stefan Wöll) #5

I still don’t understand how I can use the dragonfly as an endpoint. If I have a nuc, what do I need to install on it? I have a cirrus and woukd like to listen to music via roon on it, but I don’t understand how to connect it. I plugged in the df but it’s not detected by Roon.

(Geoff Coupe) #6

What is your cirrus running? ROCK, Windows or Linux? If it’s the last two operating systems, then have you also installed Roon on it? And if so, is Roon running?

(Stefan Wöll) #7

Hi…thanks for the feedback. I have Win 10 running on the Cirrus, since I use it as my desktop Pc for lightroom and stuff. I installed Roon on it, but I´m not able to play music. I only have the zone in the living room (Sonos). Roo server is running on a QNAP NAS. Initially I Planned to switch to the Cirrus, but I´m not sure about it, because I don´t want to haxe it turned on all day. But maybe with a On/Off schedule.

(Geoff Coupe) #8

So, if you have Roon installed on your Cirrus, then you should be able to use it as a Roon Remote (i.e. use it for the Roon user interface) for the Roon Core running on your NAS.

If your Dragonfly is plugged into the Cirrus, and you use Roon on the Cirrus, then going to the Settings/Audio screen in Roon, you should be seeing something like this, with the Dragonfly displayed as an audio device:

Click on the enable button, give it a name, and then you should have the zone created and you can play music to it.

1 Like
(Stefan Wöll) #9

Yes that is were I was looking, but the dragonfly is not showing up. Hmm. Do I have to install a special version of roon or just the normal app for windows?

(Geoff Coupe) #10

Just the normal version for Windows. Can you show us a screenshot of the Audio settings?

(Stefan Wöll) #11

Yes. thanks.

(Geoff Coupe) #12

Ah - it’s interesting that there’s no “Connected to this PC” section showing at all. There certainly should be. I wonder whether there’s a firewall issue here, and the Core is not able to see the audio devices on the Cirrus PC. Can you temporarily turn the Windows firewall off to see if the devices then appear?

1 Like
(Stefan Wöll) #13

OMG! You were right. Turning of the ESET firewall brought up some additional listings.


Great! Thank you so much. Now I need to find the blocking entry in the FW.

(Geoff Coupe) #14

Just make sure that Roon.exe is added to the Public and Private whitelists in ESET Firewall…

1 Like
(Stefan Wöll) #15

The ESET FW is so complicated. I always need to search for hours. I added roon.exe but it seems that there is something else I need to configure. I will test a little bit.
Thanks again! You really helped me a lot.

(Geoff Coupe) #16

Good luck…

(Mr Fix It ) #17

Roon appliance needs to be added too I believe

1 Like
(Stefan Wöll) #18

I found it thanks! I used the training mode and indeed there was another roon part. Now I´m happy :slight_smile:

1 Like
(Geoff Coupe) #19

Yup - missed that. Sorry…