Using HQPlayer without a streamer

I’m experimenting with using the USB out from my Mac Mini direct into my Holo Spring DAC.

Previously I have used a SOtM streamer between Mac and DAC and everything worked just fine.

Having removed the streamer when I choose the DAC as an endpoint in Roon (ie without HQPlayer) it works just fine.

Now without the streamer and going direct from the mini I’m having a little difficulty. I have NAA going, and HQPlayer can see various outputs from the Mini - just not the DAC.

Grateful for any thoughts on what I might be doing wrong.

If HQPlayer is running on Mac Mini and the dac is usb connected to the Mac Mini you don’t need NAA.
Just be sure to disable in Roon the same dac output

Have you selected ‘CoreAudio’ instead of ‘NetworkAudioAdapter’?
Screenshot 2022-12-19 at 7.33.36 pm

Don’t know macos, but in Linux hqplayer needs exclusive access to the dac, i.e. you have to disable sound daemons like pulseaudio.

MacOS uses Core Audio by default. It is the standard Mac sound system. Roon can get exclusive access to the sound output without problems. Usually.

No I had not - perfect! All working now.

My thanks.


I’ve done heaps of switching between an NAA connected uRendu and direct USB connection on M1 Mini.
Per above, when using direct USB Per all you need to change is ‘NetworkAudioAdapter’ to ‘CoreAudio’.
No need to disable the DAC output in Roon either.
You can select in Roon whether you want to use HQPlayer (Holo DAC) or the Holo DAC directly from Roon. Or compare the two using the ‘Transfer Zone’ function in Roon.

Thanks for your response - exactly right and all working now!

1 Like