Using ~~Windows~~ Linux to use Ethernet

I finally broke down and ran Ethernet to my living room.

But not with Cat 6. I used MoCA – short for Multimedia over Cable Alliance, I think. After all, coax was what the guys back at Xerox PARC in the 1970’s used for Ethernet in the first place, and the house is already wired for cable. I bought a starter pack of two MoCA transceivers, went over the cable path to make sure there weren’t any splitters in it, plugged the transceivers in, and sure enough, full-speed Ethernet.

Encouraged by that, I figured I should convert my high-end Roon system from WiFi to Ethernet. Another MoCA converter, OK. But my streamer is a Pi 3B+, and I didn’t want to use both Ethernet and USB to the DAC at the same time. And of course, Pi 4 parts are in short supply right now.

I read the postings over in the “New iFi Zen Stream device” thread for a while, then shuddered delicately and decided to try something else. I ordered one of the little MeLE fanless Windows PCs (only half the price of the Zen Stream, too, though twice the price of a Pi) and sat down with it today. I applied all the updates and set it to update automatically in the wee hours of the morning. I downloaded Roon Bridge for 64 bit PCs and installed it. With the invaluable help of @Rugby, I managed to set up the machine to (a) not require login on boot, and (b) start Roon Bridge automatically on startup.

Then I plugged it in where the Pi had been, plugged in the Ethernet cable, and scanned for it in Roon’s setup. There it is! Enable, and play music.

Update: I noticed the machine would drop off the Ethernet every now and then. To fix that, you have to find the Networking control panel, and adjust the “Power Management” setting of the Ethernet network adapter. Uncheck the box that says, “Allow the computer to turn off this device to save power.” See here. Or, if you’re one of those types who likes to edit the registry, you could do it this way.


Did it have windows 10 pro installed as advertised?

Its very energy efficient, only one degree! :slightly_smiling_face:

“Beelink GK35 mini computers use less than 1 degree of electricity for 24 hours a day standby.”

Thanks for sharing, Bill. I would have liked to witness you shuddering delicately, but hey – you can’t have them all… :wink:

1 Like

It says, Windows 11 Pro. But I ran all the updates before I looked at that. Maybe it updated from 10.

Must have a pro license to get to 11 pro.
Good little system.

Added note about Ethernet power management settings.

I have never understood the point of Ethernet Power Settings on Windows. Most applications expect constant internet connection and will complain if connection is lost. Similarly, if you are connected to storage on your LAN (NAS) apps will complain when it is interrupted. And as you have found, once a device drops off the network, you probably need physical access to it to reboot the damn thing.

1 Like

I have to admit defeat.

Every night, the Windows box dropped the Ethernet connection. No matter what I tweaked. And, being Windows, the reason for this was cloaked in a fog of event messages which made no sense to anyone not steeped in Windows lore.

So I wiped the box and installed Xubuntu and the Linux Roon Bridge. Now it runs fine, and stays connected.

@Bill_Janssen fingers crossed that it works out for you Bill.

Two words, connected standby. Windows energy saving sleep state. Pain in the arse.