V3 Firmware LS50 Wireless II & subwoofer(s)

As an owner of an LS50 wireless II system & 2 x KC62 subs I thought I would share this for all.
The recent v3 firmware pushed out to these speakers cut out the sub out channel on the primary speaker, sub out on the secondary speaker worked ok.

The resulting fix has reverted the speakers back to the issue of approx a year ago, whereby the subs will go into standby in LFE mode when listening at low to moderate volume.

The fix is to use manual mode, adjust the crossovers on the subs themselves & slide the low pass setting in the app across to the right, therefore handing it over to the sub(s).

In short, a bit of a QC own goal by Kef, pushing an update out to peoples systems that had clearly not been tested even with their own subwoofers.

I wish users were given the choice of whether to accept updates like this rather that have them pushed out overnight.

Hope this helps someone.


I’ve had exactly the same issue. LS50WII with a KEF 10b. Auto wake up for subwoofer was working fine until firmware update earlier this week.

Appreciate your suggestion for a workaround here, and noted something similar from KEF reps in previous threads. I agree it’s certainly not ideal though. And I still need to push the overall volume relatively high initially to get the sub to respond.

Nice share @Grasshopper and hopefully this will help other users who have this update and are wondering why this is happening :+1:

1 Like

Assuming you have updated the app to the latest version, select a default EQ in kef connect, then reselect your chosen EQ again, that helped to reset it for me.

Leave the setting on to wake the sub at start and change it to manual, I use these settings in the app, see below. This is with 2 subs but I still don’t need to crank the gain up, I listened all night like this at 33 volume and it didn’t drop off.

I adjust the low pass frequency on the subs themselves to what it was in the app when I used LFE mode.
I can’t tell a difference in sq,

I’m tired of all the tinkering. I hope KEF will correct the mistake soon.

1 Like

The problem has been fixed by KEF. Simply perform the update again.

1 Like

KEF writes for latest Update for KEF Connect App
(Android Version 1.19.1, iOS Version 1.19.1)

  • Fixed subwoofer out no sound issue. Navigate to EQ Settings and switch to Default profile and back to current profile
1 Like

Thanks everyone, and especially @Grasshopper, for your help & support to fellow LS50WII users. Greatly appreciated

1 Like

Good to see everybody up and running again. Between the update and the fix, I was without my KC62 for one night. If anything, it made me reappreciate what it brings to the music. :wink:

Pity that the whole upgrading mess has overshadowed the addition of two new options that make my life just a little bit easier: the option of setting a startup volume for all sources individually and the option for the HDMI/TV signal to override audio already playing when the TV is switched on.

In the 2,5 year I have the speakers, KEF has steadily added worthwhile functionality. They are one of the few manufacturers that seem to understand that software development does not end when the product is first shipped – and keeping the LS50WII current with third party software library updates (Roon, Apple, Spotify, Tidal, Google, etc.) adds value. I can live with a small hiccup every now and then.


A slider within the app to choose when to apply updates or a method of reverting back to a previous firmware level, would have helped. I have no other device where the receiving of updates is handled like this. The only way I can see to stop them is to disconnect the speakers from the internet, which may be possible at router level, I haven’t tried and shouldn’t have to.

I’ve learned a lesson here, if a device I buy has the ability to update firmware, to check how that is applied.

And Kef didn’t reply to my service requests, I am in the UK and called their service and was promised a call back, even told the name of the person who would call, but it never happened.

Let’s not forget the initial issues with these subs that took an eternity to resolve and workarounds from the beginning. We should not have to tinker to get an all Kef system to work with parts they were designed to work with.

Anyone else have a constantly blinking ‘TV’ “OPT” 'Mute" symbols on their main speaker? I have the new auto TV input switched to off, but it won’t go away. Works fine otherwise, but seems like a bug.

I’m glad the 1.19.1 update has helped some. Sadly, I’m still in permanent standby mode. Not clear why it didn’t work for me.

I’m exchanging email with KEF support currently…

My KC62’s are going into standby again, in LFE mode and manual, at volume 30 they both cut out after 10 minutes or so & I can clearly hear that they are working and providing rich bass, they just cut out mid track. Raising the volume to 37 or switching the system off & on again wakes them up, for another 10 minutes. I’m furious about it really, that a company can torpedo someones music setup remotely with an unrequested update with no means of reversing it. I have reported via the app & will call Kef tomorrow, I will also call my local trading standards & see if they can get involved & hold them to account.

@Grasshopper I’m glad you contacted support.

When I first emailed them, Kef support advised that the standby problem “did crop up for a few customers.” So either the problem is not widespread, or they have gotten relatively few reports of this issue. There is supposed to be another update at some point.

Currently, I’m trying to find manual settings which will keep the sub out of standby and still sound good.

If only I could roll back to version 2.5, that golden moment when everything worked. Sigh.

Good luck. I’ll update this thread with the outcome.

This just in:

Version 3.1

  • Enhanced Wake sub on start-up behaviour to ensure continuous subwoofer operation, even when audio is played at lower volumes


1 Like

This update to firmware 3.1 fixed the problem for me. The sub no longer goes into standby, in LFE mode, while I’m listening to music.

1 Like

Same here. I also discovered that pre this update, they didn’t sleep when using Tidal Connect, they DID sleep when using Roon.
It’s fixed now, until the next time.