Verizon 5G won't connect to ARC port

Roon Core Machine

Catalina 10.15.7

Networking Gear & Setup Details

Verizon 5G home internet

Connected Audio Devices

Sonos paired

Number of Tracks in Library


Description of Issue

Shortly after ARC came out I tried to connect to the port and got a “not ready” message. I tried to work through it but as I noted then, I am not nor do I intend or wish to be a computer programmer. I just want to listen to my music.

I have been out of town in the interim, so am just getting back to trying to figure this out. Hint: I’m not interested in a bunch of techno-geek advice. I would like to talk to a Roon rep about the specific issues posed by Verizon 5G - whether they have been addressed, and, if so, whether there is a work-around that someone from Roon can walk me through. If this issue has not been addressed, can someone put me on a list and notify me when it is? Or, alternatively, just tell me I’m SOL on this system so I’ll stop worrying about it. Thanks much. randyb

Your fixed internet connection at home is a 5G router that connects to the internet via the Verizon cellular 5G network? This kind of connection typically does not provide a real, routable public IPv4 address, which is needed for ARC (and similar usage like online gaming).

However, maybe you are lucky: They have this help page, which seems to describe exactly what you need:

Please copy and post the error message that is shown in the Roon app under ARC Settings. This should help figure out why it’s not yet working for you.

Roonlabs have said that they are working on a solution that does not require port-forwarding of an IPv4 address, as inability to do so is quite frequent nowadays among ISPs. (IPv4 addresses are running out and the internet infrastructure is slowly moving to IPv6, which does not have such a restriction on the number of possible addresses). However, nothing specific is publicly known, and no expected release date.

1 Like

Hi @Randy_Bradbury,

Since some time has passed, have you had any luck automatically configuring port forwarding?

Please paste any diagnostics from the Roon → Settings → ARC page if not, and the team will happily provide troubleshooting steps for your specific case.

Thank you.

No luck. I’ve been waiting for contact from Roon support staff. So thanks for getting back to me.

Here’s the start of what I think you’re looking for:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

There’s more, but the last time I tried to provide this kind of info, someone told me a hacker could use the info to get into my computer. Let me know if you need the rest, assure me it can’t be used against me or let me know a more secure way of communicating it to you. Thanks. randyb

1 Like

When it was new, the error message included the external IP address (if one is available). In an extremely remote possibility, a bad actor could use this address to “find” your router’s public interface over the Internet. However, that doesn’t buy the bad actor anything. In reality there are automated port scans on the Internet anyway, which find the public interfaces and try if a connection is possible, there is no way to avoid that whatsoever.

In any case, the external IP address is now obfuscated in the error message of current Roon versions, so posting the error message is no problem.

If you don’t want to, click the Roon logo in Connor’s post, then click the Message button to send it to him privately.

1 Like

Hi @Randy_Bradbury,

Thank you for your private message and further clarification. Since the advice I’m going to provide below doesn’t pose and security risk, I’ll go ahead and return to this public thread for the benefit of other users.

As @Suedkiez mentioned above, 5G home routers will assign a public-facing IPv6 address to your network. Roon has implemented some solutions for IPv6 addresses, but this won’t necessary work with every carrier. At the risk of diving into jargon, let’s first double-check some hardware setup on your local network:

  1. Do you have any additional routers or switches beyond the Verizon 5G router? I know some older threads you’ve posted have mentioned other makes and models of home internet hardware.

  2. What is the model of the Verizon router? Most customers have the Verizon 5G Gateway or the Verizon 5G Home Router, based on this article.

Depending on the Verizon router’s model, you should be able to use the instructions above to set a port forwarding rule using the router’s web administration page. This shouldn’t be too difficult, and we’d be happy to help you step-by-step.

  1. Lastly, do you have any firewalls or VPNs enabled? The IP address from your account diagnostic reports to our server doesn’t always match that displayed in the diagnostics from Roon → Settings → ARC (from your private message).

We’ll be standing by for your response. Thank you!

A. I do not have anything beyond the router. It functions as a wi-fi hub, so all of our devices connect directly to it via wi-fi. For Roon, that means my core computer (an old iMac running Catalina 10.15.7 and drawing off an external hard drive with our music files), an iPad as Roon controller, and paired Sonos speakers.
B. Verizon 5G Gateway.
C. I do not have a VPN - because I got rid of it as it was always making me fuss incessantly with Roon every time I wanted to listen to music. However, I have a VPN when I first started corresponding with you, so perhaps that accounts for the discrepancies.
D. I’ve been waiting for several months hoping someone would offer to walk me through the process because my attempts failed.

OK, here’s where I’m at:
Verizon port forwarding instructions do not match the screen I get when I log in.
Instructions say:

  • Go to System settings (there is no such tab or link)
  • Go to Firewall (there is a Firewall button, but it’s on a secondary level under "Security).
  • Go to “Port Forwarding” (there is no button or link with that label)

There is a “NAT forwarding” button with the following buttons:
- UpnP
- Virtual servers

I went through all this months ago with Verizon tech support and I remember being in this latter part of the menu. But after a long, long, long time of waiting, then trying to actually do this, it still didn’t work.

This is why I’ve been waiting for someone with Roon to walk me through this, or fix the issue, or water.

What is my next step? Am I just waiting for someone to get back to me on this thread? Is there anything I can do to expedite this (after five months?).

Thanks much,


Hi @Randy_Bradbury,

“NAT forwarding,” in the context of the router web administration menu you’re describing, likely refers to the port forwarding settings we require.

ARC has two mechanisms for connecting to your Roon Core on the go via your router, one of which is UPnP. If you select that option from the “NAT forwarding” menu in the router settings, what options are you presented with? There’s a chance we can finish what the Verizon rep started with minimal tinkering.

To expedite things, are you able to share a screenshot of the Settings page in the router web administration via our private message chain? Thank you!

Hi @Randy_Bradbury,

I’ve done a little digging. For the model of Verizon gateway you’re using, there should be an option to set a manual port forwarding rule (TCP) under the “Virtual Servers” option.

In the Verizon Internet Gateway web administration, navigate to NAT Forwarding → Virtual Servers and select “Add New” under Binding List. Fill in the fields using the information listed in Roon → Settings → ARC. It should resemble this:

Here’s an article from their website. Hopefully, this helps!

I answered this, but don’t see my answer. Did you get my reply? Basically, the only thing I see when I go to Settings > Roon ARC is the dialog from the test, resulting in the message “not ready,” and these values:

Roon Core IP:



I’m not at all sure how to translate that into the fields on the Verizon form (I did find the form, thanks).


Just to add to this since I just set up my Verizon 5G Gateway yesterday and ran into the same errors with ARC… I came here looking for this exact help.

All I had to do on the Virtual Server page under the Verizon Admin is: 1) hit ‘Add New’, 2) select my roon core machine from the drop down menu under the Client field, 3) enter my ARC port number four times (twice for the external port fields and twice for the internal port fields, the same number each time), 4) Protocol = All, 5) be sure to hit ‘Enable this entry’ up top so this ‘virtual server’ is active.

Once I hit save and saw it was active under the virtual servers list on the Verizon admin page, I went back to Roon and tested Arc, which came out with a clean bill of health.

I hope this helps.

Yay. Yes, thanks Rian. That worked. Thanks to Connor, as well. Between help from both of you, I finally got this figured out. Rian’s instructions worked perfectly.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.