Verizon Fios and Netgear Orbi [Solved - Bridge Mode, Turn Off UPnP on ISP Router]

Excited to try things out now that the mobile-ext build got pushed out. However, networking is my technology weak spot and I can’t get things working from either a UPnP or port forwarding standpoint.

My ISP is Verizon Fios (I’m in the US, upstate NY) and the Fios router is a G3100, firmware Wifi is off and the router is connected to a Netgear Orbi router in AP/bridge mode, firmware There is one satellite up on my second floor to get better wifi to my attic where my son has his Playstation.

My core is a 2021 MBP connected to the network for wifi. I recognize this is not best practice, and I will eventually transition to a NUC connected via Ethernet, but I haven’t had any issues playing to a number of different devices via the various protocols Roon is compatible with - Sonos, Chromecast, Airplay.

My router settings don’t have either a UPnP nor Port Forwarding tab. Everything I’m seeing online indicates they should be there, but they are definitely not.

If anyone has had any luck with similar equipment and could walk me through the setup, I’d greatly appreciate it! Glad to provide any additional info that would be helpful. Thanks!


Quick update - UPnP is enabled on the Fios router, the setting wasn’t where the manual or any forum/support posts said it was.

And, turned UPnP off, restarted Roon and now I’ve got the “Ready” I was looking for.

Fingers crossed it stays that way!

1 Like

I have a similar setup. Orbi RBR750 in bridge mode with Century Link fiber.
Your Orbi should have an external IP address under WAN settings
So long as your Verizon Fios router is passing everything through to the Orbi, no settings should matter on the Verizon box.
There is a Port Forwarding screen on the Orbi, and you should be able to confirm this using other websites like etc.


Thanks for the info. As far as I know, everything is passed to the Orbi. I can find the Port Forwarding screen in the Orbi admin webpage but it’s grayed out, no way to make any adjustments. There’s a screen shot below.

I did get things working by switching off (yes, I know, I really did switch it off, not on) UPnP on the Verizon router. I don’t know if it was coincidence or not, but when I restarted Roon after making that change, it was good to go.

I’ll keep this up to date with any changes. Thanks again.

edit: whoops, forgot the screenshot, here it is:

1 Like

Hi @kneville,

Thrilled to hear it’s up and running and thanks for including your details in this subcategory. The precision is truly appreciated.

Looking through logs, the Orbi router is likely correctly configured in Bridge mode, passing the correct IP to the Core and doing the heavy-lifting for the port forward as @Rutherford suggested. So, it makes sense that disabling UPnP on the Verizon unit would work here.

Please keep us updated if anything changes! Once we know we’re in the clear, I’ll go ahead and cement this thread as a guide in our #arc-testing:port-forwarding-solved section.


Ahhhhh the Orbi is in bridge mode. In my setup, the Century Link box is in bridge mode.

I needed this so I could specify a different DNS server to my DHCP clients (

Update to my setup, Core and network. For years now, I’ve run two cores, one at home, usually my laptop, and one at my office, formerly an iMac, more recently a 2014 i5 Mac mini, with an internal SSD for the database. I tried out ARC for the first time at work today and it ran without a hitch.

I brought my office Mac Mini home, installed Roon Server on it, and migrated my home database to it, now running my laptop as a remote. The Mac mini is connected to my network via ethernet. Initially, I had it connected to the Orbi (in bridge mode). No luck configuring ARC. Then I switched the connection to the Verizon router. No luck configuring ARC. Then I turned UPnP back on (I had turned it off previously when my core was a laptop connected via wifi) and seem to be back up and running with a new core that will let me bring my laptop to work and use ARC at work.

I’ll update if the situation changes or I run into ARC-related network issues.