Verizon FIOS - Quantum Gateway Router G1100 Solve "Poor Connection" Issues with Manual UDP Rule

Verizon FIOS user here who has been having the “Poor Connection” issues with ARC.

Just wanted to post my solution - I’m not sure you actually need to turn off UPnP as suggested here.

The UPnP feature of this router successfully sets up the TCP port forwarding that Roon’s core sets up.

HOWEVER - it does NOT set up UDP port forwarding.

If you go into your router’s admin and manually add the UDP port forwarding using the same port as selected for TCP forwarding, the “Poor Connection” issues go away and ARC works like a charm.

Note I did not have to change any other settings, and didn’t have to turn off UPnP to get this to work.

1 Like

Great info Brian. I too have FiOS. Did you just add UDP or did you have to specify a port?

Hi @Brian_Benitez,

Thank you for your clarifications here. I’ve moved this to the #support:port-forwarding-resources section so it doesn’t get lost as a beacon to other FIOS users. The thread should stay open now.

John - I did set the UDP port to the same port as used for TCP.

Also, there’s a setting buried deep in the FIOS router admin about automatically “cleaning up” UPnP connections. I also turned this off, which seems to have been helpful.

Likely the most stable set up with this particular router is to set the port forwarding permanently/manually, vs. using UPnP due to the oddness of how that works with this router.