Vero 4k+ as Roon Endpoint

Hello all,

I’m wondering if anyone else here is using their Vero 4k with both OSMC and Roon. I’m successfully running Roon bridge on my device but after listening to music OSMC struggles with playback (really high resource utilization) until after a reboot. Thank you in advance for any suggestions!

i occasionally listen to multichannel rips in my HT with a Vero 4K+. Has your Roon Bridge updated to the latest version (mine has). Are you using NFS or SMB to mount your music files ?

Thank you for the reply.

My Roon Bridge is the latest version. My Core is running on my Synology NAS where my music is also stored.

Update: I upgraded the Vero to Kodi 19 and now I have no sound from Roon.

I updated tonight to Kodi 19, watched a 4K UHD film, then tried to play some music. I noticed that I had to reinstall Roon Bridge, it was not running, some of the files were still there, but I decided to reinstall.(as root)

  1. curl >
  2. chmod +x
  3. ./
  4. go into the App and configure the Zone, enable the device on the OSMC endpoint, it will find 3 audio devices, choose the first ALSA, enable it, go into advanced settings and change 2.0 to 5.1 or 7.1, depending on the number of air-moving devices in your room.

I tried samplings from two multichannel FLAC albums, they both worked fine.

I am interested to use my Vero 4K+ that way but I am afraid steps 2&3 are cryptic to me.

Would you be so kind to explain more please?

  1. Download the install script
  2. Make it executable
  3. Execute it

SSH into your Vero 4K+ by following the following steps…

Then enter, line by line, hitting enter after each line, the steps in @mjt5282’s post above. The last line will ask you to enter the password you used to SSH into your Vero 4K+

curl -O
chmod +x
sudo ./

As a long time owner, I use primarily the Vero 4K+ as a Plex client to stream 4k UHD TV shows and films. It can bitstream Dolby Atmos and DTS’s lossless spacial audio format. It cannot currently passthrough Dolby Vision, which is fine because my 4K projector (JVC) cannot handle Dolby Vision anyway. It runs Linux kernel osmc 4.9.113-45-osmc currently after the Kodi 19 upgrade, I am running it dual stack ipv4/ipv6 . The multichannel PCM (FLAC) rips are working fine through RoonBridge and it is currently on sale (quick shipping from UK to US, at least for me when I bought my last one).

Great thanks @Nickpi, @j_a_m_i_e and @mjt5282 !

I will try that out.

I am using straight osmc/Kodi for movies mainly and Plex for TV shows and music out of the house.

I have seen the update displayed but had a crowd waiting for the show, so postponed it! :grinning:

I’ve reinstalled roon and rebooted the device. I’m still getting no sound from roon, it’s very strange.

I’ve been running Roon Bridge on my Vero 4k+ for a few years without issues.

John, I would double check the audio devices you have enabled for the Vero 4K+ zone and maybe test another likely candidate for audio output.