VitOS stuck on RPi 4 bootup

I’m trying to use VitOS as a Roon endpoint to compare to RopieeeXL, which works fine on my Raspberry Pi 4 right now.

I’ve used both Balena Etcher and Win32DiskImager to write the VitOS .img file (from VitOS’s redirect to Sourceforge) and both times I’ve ended up stuck on boot, first here:

Then here where it stays:

Does anyone know what this means or how to get around this issue?


You may just need to update your Pi firmware, see here and following excerpt:

Overall, updating your Pi 4’s firmware is simple and straightforward. An overview of the steps is as follows:

  1. Ensure you’re connected to a stable internet connection.
  2. Check what version of firmware your Pi 4 is running to see if you need to update it. You can do this by opening a new terminal window and entering the command sudo rpi-eeprom-update.
  3. If it flags that an update is available, as we mentioned earlier, one option is to run sudo apt update followed by sudo apt full-upgrade to fully update your Pi’s software, firmware included.
  4. To only update the firmware, use sudo rpi-eeprom-update -d -a instead.
  5. Once the installation process is done, reboot the Pi by typing sudo reboot*

After Reading your message, I went to the vitos website and I was able to create a flash drive and start vitos on rpi 400. Then I installed vitos manager on iPhone.
The vitos manager sees vitos on this rpi, but when I make (in that app) the choice to install roonbridge I get during the download proces - Again and Again - a failed data integrity check.
When i go to the forums of vitos i do not see any help and the forums are also closed for new massages…. Red flag for me: I am used to the quick help from Roon members and Ropieee.

I startend with RopieeXL on rpi2 and rpi3 and when Ropieee gave up the support for rpi2, I installed dietpi + roonbridge on the rpi2 (and also the Roon extensions)

So Maybe test dietpi as alternativ?

I loaded Dietpi up on an SD card and checked the Roon Bridge tick box and now I am running it successfully as an endpoint.

Then I ran sudo rpi-eeprom-update via SSH and it says my version is 000138c0 which is the latest, so that won’t work. I’ll keep messing with it for fun though, and we’ll see what happens.

1 Like

I also have the same issue. I have two PI4, a 4GB and an 8GB model. I have updated the firmware but still experiencing the same issue. I hope someone can find a solution soon.

Looks like you have to boot up some new distribution like Dietpi, copy the start4.elf and startup4.dat files (and maybe some other .elf files from the /boot directory) onto a USB then copy these to the VitOS SD and overwrite the older VitOS files. Then you can boot to the VitOS distribution.

I haven’t tried this yet so I can’t attest to it working. Seems like VitOS needs to update their software for the newer Raspberry Pi boards/firmware.

Fixed it! Put new SD card in PC, use Balena to write latest Dietpi to card. Then open newly imaged Dietpi SD in File Explorer and copy all .dat and .elf and anything like that from SD root to temporary PC folder. I did 16 files I think.

Eject dietpi SD and put in VitOS SD and copy all files from temp PC folder to VitOS SD card overwriting any copies. Eject and boot now fixed VitOS card in RPi — works! Sounds great too. Seems clearer than dietpi.

Since it’s so easy to power down the RPi and switch out SD cards I’ve done back to back comparisons between VitOS and dietPi and there is a definite difference. I think the VitOS is cleaner and it’s easier to hear singers breathing, background noises, etc. But it’s also a bit thinner sounding. That may just be the way my stereo really sounds though – I’m not sure.

It is interesting that there is enough of a difference that it’s easily recognizable. Well worth the $8 for the SD card.

An update: I had installed some new things in my system that were the cause of the thinness in sound. VitOS is superior in sound to DietPi, which was better than Ropieee. System sounds wonderful now and VitOS is a rock – just keeps working, no issues. Nice that they give this away!

How dan you call it Vitos while you copied 16 files from DietPi?

I just made it work. I’m no expert on what’s what with Linux distributions.

1 Like