Volume resetting to 0

Just started to see a very odd problem with one of my ropieee zones - where the volume resets to zero. When you try to set a volume of anything but 0, the slider just drops back down.

@spockfish is there anything in the log that gives a clue to what might have gone wrong?


Try this…Various reboots not effective, however, one reader suggested deselecting device volume in favor of fixed. Save, then reselect device volume & save. Slept on it. When I played a track this morning, all was good. Of the many things I tried, I believe that device/fixed volume trick seemed to be the charm.

Thanks Mac,

So I just tried.

If I select dsp volume I can move the volume slider OK, although no sound comes out of the HAT.

If I switch to device volume, the slider resets to 0.

Greg…Although my issue was with volume quickly rising to 100 (that’ll startle you!) it sounds similar to your problem. I’m sure you’ve powered down, rebooted, etc. Try reloading Roon remote app, check for device volume & see what happens.

And since your issue is a particular zone (I have only one zone), make certain the adjustment you make to fixed/device volume control is for zone in question?

Thanks - I have other zones (also ropieee/DAC2 HD) that still work normally (I tried multiple remotes - and disables the things I usually have calling the roon api - no joy)

It suddenly stopped working, so my guess is it’s a HAT or Pi problem.

I’m hopefully there will be something obvious in the log.

Next step is to swap sd cards / PIs / HATS…

Hi @GregD

You started the other thread… which is about the same issue afaik?

No - I’ve avoided upgrading to the latest ropieee on my DAC2 HD hats since I saw your warning.

I’d be surprised if this is a ropieee issue - but would be very grateful if you could check the log to see if there are any clues…

@spockfish I burned Hi Fi Berry OS to a spare SD card, expecting to find a hardware problem, however it seems to work fine.

I guess with the current (unsupported) state of the DAC2 HD on the current build of Ropieee there isn’t much point trying to debug, but let me know if you want me to do anything.

Will switch back when / if it’s possible to support again.

I still have 3 other Ropiee builds running DAC2 HDs!