Watched folder not being scanned

@support

I have roon running as ROCK on an Intel NUC with music stored on a QNAP TS251+ and mapped to roon as a shred folder.

When I add a new ripped folder to the audio storage Roon is not detecting this, scanning and adding to the library.

I have to go into settings and force a rescan for anything new to be picked up.

Same issue here

The world of NAS seems to be like this. I recall being able to set the time between rescans to a smaller amount. But scanning “upon need” seems elusive.

It used to work fine when I was running roon on a Mac Mini (my audio files have always been stored on the NAS)

@thebiglebowski — This is a symptom of how real-time file watching works on Windows, vs on Linux or OSX.

Remember that SMB is a Microsoft technology–it’s a first class part of the Windows ecosystem in a way that it isn’t on Linux and OS X. One result is that Windows tends to be a bit better at picking up changes on SMB shares in real time.

We’ve made some improvements to Roon’s filesystem watching behavior over the years, many of which were released with Roon 1.3, but ultimately when the operating system fails to deliver file system change notifications to us, there isn’t much we can do, aside from waiting for the Linux and Apple SMB implementations to get better, and deploying updates to ROCK as they become available.

Long term, we would like to provide more options for avoiding SMB in NAS-based configurations–perhaps by extending Roon Bridge so that it can run on a NAS and speak a protocol of ours instead of relying on SMB. We don’t have a timeline for that work, but feedback like this is definitely taken into account when we write our schedules.

All of that said, we tend to hear symptoms like these more with other brands of NAS – QNAP and Synology are usually reasonably solid, so you may want to check your SMB settings. It’s possible you can do better here, so feel free to post your settings and we can see if there something obviously wrong here. You can also change the re-scan frequency of your SMB mount in Settings > Storage.

-Eric

A post was merged into an existing topic: Album or tracks not imported or scaned

I am having the same problem, but with an NFS share mounted in Ubuntu. It appears like a local folder. I can’t see any option to change scan frequency. At the moment I’m having to force rescan to get it to pickup new music in the folder.