Weak volume output on DietPi Raspberry 4

So, I tried RoPieee again and did not care for the sound quality on my Raspberry Pi 4 endpoint. So, now back to DietPi, and all is better, but there is a question I continue to have. Is there a way I raise the overall base volume? As my Pro-ject S2 DAC seems a little quiet.

Quiet compared with what??? The Roon Bridge simply converts the data stream from your Roon core to a format suitable for feeding to the DAC, so it will have no effect on volume UNLESS you have deliberately introduced some digital manipulation of the data stream (perhaps without realizing it). Here, there are a few things to check:

  • Check your device setup in Roon–for your DAC, I think Volume Control should be set to fixed volume output, so that you will control volume solely with the knob on your DAC.

  • Make sure that no processing (DSP) is being applied; in particular parametric EQ could be affecting volume if enabled. Disable DSP for troubleshooting purposes.

  • If you are comfortable SSHing into your DietPi box, run dietpi-config --> Audio Options --> DietPi-Justboom --> ALSA Mixer and check the ALSA mixer settings to ensure no EQ is being applied. Unless you have a specific reason to be doing EQ in the bridge, disable it by setting EQ Enable to [Off].

When I say said quiet, I mean other inputs. I found this options, for some reason it was not at full when I checked it. I changed that, and not it is all fine.