What am I doing wrong here

Been a trial subscriber to Roon - Finally took the leap to yearly membership. No regrets - have always loved Roon. The thing that I struggle the most is - variety of songs. How to get Roon to play the vast library of music from Tidal? For example - if I choose Easy Listening Genre - it will always play Kenny G from my library until the cows come home. I am certain there are million more artists and songs under Easy Listening on Tidal. Another example, I choose Folk it will play all songs from my library. Sometimes I get tired of hearing the same song repeat. If I do radio i will hear repeat of songs every one hour.

Please help me figure this out so I can optimize Roon and really begin to enjoy it’s potential.

Personally I don’t find genres very good starters for roon radio. Have you tried starting from tracks instead?

@ged_hickman1 thanks for the reply and I agree tracks are good for starting radio. Does that mean genre or Discovery will always limit you to what’s in your library?

No but I personally think genre is very limiting. Many albums are tagged with multiple genres, tagged wrongly (or with genre rags I would disagree with) so you limit the range. This I must stress is my personal opinion!
I am reading in to your post that you want different tracks than you currently get. I would start with tracks that are to the edge of your main listening path and that may lead to more interesting radio.

For random playing , I have a mental list of “Starter Tracks” depending on what I want to listen so I just choose 1 and let Roon Radio do the rest

eg Smooth Jazz - starts Dave Koz - Careless Whispers

You always get a new “list” it isn’t the same old list rehashed especially since Roon seems to look in Tidal before your local library

As Ged says Genre is not a good start the Genre allocation can be a bit flaky !

Like any new software you need a while to settle in and find the best way to navigate. I found navigation classical music I simply had to change how I started looking , now “I’m Trained” it works fine

Good Luck

1 Like

Just checking… do you have ‘limit Roon radio to library’ selected?

1 Like

Good question - I was thinking the same.
Setting can be checked here:

I do not have the ‘limit Roon radio to library’ feature turned on.
@Mike_O_Neill - excellent advice. I will take what I learned here, start with a track and let Roon radio pick it up.

I play a full album and let Roon Radio jump off from there. It’s always a very good mix of my linked music plus non-linked Tidal and Qobuz music.


How big is your library now? Have you ‘favorited’ many artists? How often do you add new music to your library? How diverse are your music choices when you play music?
RoonRadio’s song choices are based on what you start from (the seed, here), various dimensions of your library and listening habits, and what other Roon users listen to. As you expand the diversity of your library and listening habits, RoonRadio should take that into account.
Now, there are plenty of posts that will attest that it doesn’t work that way for them, with results somewhat similar to what you are saying. This seems to be worst in certain genres, and Easy Listening or “70’s Rock” will probably produce some fairly mundane choices because some folks tend to listen to the same stuff over and over again (at least that’s my guess). IMO this ‘regression to the mean’ as some folks refer to it, is a weak spot in how Roon Radio works. But your library and what you play are important determinants too.

I have around 2500 albums and over 9000 tracks in my library and I add to library pretty much everyday. It is improving I must say and I believe the key take away from this thread to start Roon radio from tracks and not genre. But I truly wish that Roon could play music outside my library if I were to select from a genre or a label/artists from the Discovery tab. Maybe something that Roon engineers can improve on. It’s an excellent software otherwise.

I think I know what the problem is.
When you click on a Genre you get a blue button that says “Shuffle”. Shuffle is limited to your library. If you click the down arrow to the right of Shuffle you’ll have the choice of Shuffle or RoonRadio.
Have you tried clicking on RoonRadio rather than the default Shuffle?


Scott G - sir you are a genius. You should be chosen as member of the year and award a free Roon Nucleus. It works - I accessed Roon genre and instead of choosing Shuffle selected RoonRadio and voila it worked. Roon now entertains us with wonderful folk (chosen genre) music. Thank you for helping. Case closed.


You’ve clearly never talked to my daughter…
Glad you found what you wanted!

I’ve just tried this. Excellent! Thank you.

Although selecting ‘Folk’ and getting Suzanne Vega was a tad unexpected…


If she’s appeared as a guest artist on a folk album, appeared on a compilation etc …
Weird things happen with using Genre.

Ha ha never thought you weren’t choosing radio :stuck_out_tongue_winking_eye:
Well done @grossmsj

This may not be terribly helpful to OP, as the Roon-Radio-from-Genre seems to give what they wanted, but: I tend to start Roon Radio from a particular album that I use as a seed (rather than from a particular track that I choose as a seed). That’s been working for me, and (for me) it feels like less mental effort in selecting a starting point than choosing a track would… YMMV!