Which HQP Filter are you using?

Oh I see, why didnt I realise that dsd128 was 6144000 lol

Ok, so I have just tried upping the limit to 6144000, leaving rate in auto and removing 48k dsd…didint work.

I have now tried the same but setting the rate at 6144000 to be the same as the limit and it worked

So, playing back a 24/192 file, shows as DSD128x48. If I go back to auto and 48k dsd checked shows the same.

If I set the limit as 5644800, a 96khz file will represented as dsd64x48

so Im unsure what the best route to take is. I honestly cant notice any issues with selecting 48k dsd but is it better to deselect this and have both rate and limit to be 6144000?

Cheers

So after playing a whole evening with DSD 6144000, Sinc - M, ASDM7EC, im finding my Antipodes CX isn’t too happy with the extreme temperature from quite high CPU usage (All core upto 75%)

Ive tried some other filters but don’t find that they are any better than when im using PCM 352.8/384 Sinc-M LNS15.

Im going to try bringing down the sample rate to DSD64 and still use the same filter/modulator, to see if the temps/cpu usage comes down but still sounds better than PCM

Bill

Bill…Can I suggest…use ASDM5EC instead…less demanding…for device to use

Hey…I did try that yesterday is seemed to be quite high, however if I change it from the start I may get different results, as the temp at the time was silly hot (to the touch)

EDIT - Ok Ive tried that and the CPU load is still quite high, very very similar to ASDM7EC. Ive now knocked down the rate limit to 4096000, keeping ASDM7EC and Sinc- M and the load has come way down from an average of 75% (all core of 6 cores) to this. Yes its more than PCM 352.8/383 (around 11%) but its much lower than with 5664000 or 6144000

Now for some critical listening to see if the DSD64 combo of Sinc-M and ASDM7EC is still preferred to PCM Sinc-M LNS15 at 352.8/384

Bill

Cheers

1 Like

If you don’t notice issues with DSD128x48 (6144000), then it is likely fine. If you turn off 48k DSD setting, these x48 rates won’t be used.

A post was split to a new topic: Installing cooling fan on Antipodes CX?

@jussi_laako I currently use a VST host with some plugins, so my chain is Roon -> Virtual Audio Cable 1 -> VST Host -> Virtual Audio Cable 2 -> HQPlayer -> NAA
Because of VST, I use a fixed input sample rate of 44.1khz. With this in mind, would not a convolution file with sample rate 44.1khz be best to use? If I use any higher, it will just be down-sampled, right? Or when is the convolution done in HQPlayer?

Btw, I tried some convolution VST plugins, but none of the ones I tried sounded as good as when done in HQPlayer.

In such case you can use 44.1k convolution filter because convolution is performed at the source rate (PCM or DSD), with only exception being DSD -> PCM playback case, in which it will be performed at 1/16th of the source DSD rate.

In other cases it is best to use either 192k, 352.8k or 384k filter. Which enables you to avoid use of “HF Expand” option, because filter will already cover all source content’s frequency spectrum without it.

I don’t say “down-sampled” to avoid wrong impression. I say scaled, because the filter is converted to a necessary format using algorithms specifically designed for that purpose.

1 Like

Ended up scrapping the whole VST host thingie anyway, for whatever reason the VST host and/or plugins lower the sound quality to much. So back to Roon -> HQPlayer -> NAA

The reason I wanted to give VST hosts a try was to try out some tube/saturation plugins. Any chance you could make some filters that takes the sound that way? IIR sort of works, but removes something else instead, ext2 sounds excellent and takes a small step in the correct direction, but more would be better!

Do these modules introduce distortion ? That’s quite a different philosophy to implementing digital filters that make varying compromises within mathematical constraints but aim for the lowest distortion.

Well, if VST plugins (or any DSP) introduce distortion is almost a philosophical question. But be that as it may, they do introduce an asked-for change in sound, in the same way as for example tone controls or PEQ.

But I am not asking @jussi_laako do do a tube-dsp thingie, just asking if its possible to make IIR more sinc or ext2 more analog sounding.

Does anyone experience this: when you chose Poly-sinc or any non-integer filter the result still end up with an integer up scale ?

How to fix that in the HQ Player Desktop 4.5.1 ? (It’s happen only HQ Player Desktop 4.5.1)

Btw which one is a better player if we use the same filter to only listen to music : HQ Player Pro 4.5.0 or HQ Player Desktop 4.5.1 ?

Please make sure “Adaptive output rate” is unchecked or grayed. If it is checked, then that will happen.

1 Like

In REW, the convolution can change at higher frequencies when changing sample rate, for example a smooth decline between 15khz and 20khz in 44khz might be a sharp one at 96khz. Does your scaling works the same or will it keep the “look” of the convolution file after scaling?

Filter behavior won’t change by HQPlayer.

I would also expect same to be the case for REW, but when you are viewing graphs, you need to take into account that at higher sample rates the graph spans wider frequency range, so at double sample rate 1 kHz wide notch will be compressed to half the width on graph which may make it look steeper. Or are you looking at the same graph frequency spans in both cases? Also note that you cannot change the sample rate after filter design without redesigning filters…

Not sure about the technical reasons, but I remember having a filter at 18khz in REW, then I generated convolution files for 44khz up to 192khz. Then I imported the 44khz and 192khz convolution files into REW again and they looked (more or less) the same at lower frequency, but the filter at 18khz didnt look the same. And not only that, but they sounded different as well.

Maybe it works correctly only the other way around. Been a while since I used REW, but I think you need to set the sampling rate first, before creating filters.

Thanks you ! Btw I enabled CUDA offload but i don’t see my GPU % while playing music why is that ?

Which OS and GPU are you using? You have latest Nvidia drivers installed?

MSI GTX1060, windows 10, newest driver sir