Why does Roon sound distorted?

I wish Roon had the SQ of Pine Player. It’s far cleaner.

Hi there from a fellow user.

Specifying titles and timestamps would greatly enhance helpful feedback.
Be more verbal about your entire system setup, connections etc.
Maybe show us screenshots of your signal path, DSP and device settings please?

It seems likely, that you’re using a Roon-DSP function that needs headroom adjustment due to causing clipping.
To remedy, enable and adjust headroom as described in Roon’s helpcenter, see screenshot …


… and …

Good luck!

Hi Marin

The artist is “The Gotan Project”
The Album is" Lunatico"
The track Diferente at 2:25-2.40 is distorted using Roon and not distorted using Pine Player.
I’ve added headroom management and no clipping is shown (nor in the interface to the DAC either) - but the sound is still distorted

I’m using it currently on my desktop system
Although plans to use it as a house wide system (including out to my old squeezeboxes) are very attractive
There’s no doubt that the interface and integration is streets ahead of Pine.

I had talked myself into - £800 over 5½ years isn’t that bad

  • However sound quality comes before convenience and pretty displays
  • so if I can’t find the cure, the trial will be over…

But what does your signal path look like and are you using any other DSP?

I’ve just listened to the track on Qobuz and there is no distortion on it.

Do you have access to Qobuz or Tidal to rule out something amiss within your local file (I realise it’s playing in Pine but always worth a try).

One often has people preferring other music players but roon is rarely accused of causing distortion so I’d imagine something else is happening here.

.sjb

As Boris says above, what does your Signal path look like? Can you post a screenshot?

It might be worth checking two things:

1/ That you are using the CoreAudio output on your Mac under Settings->Audio

2/ That you have Exclusive Mode enabled under the Cog wheel->Device Setup


That will ensure that the audio from Roon is sent directly and bit-perfectly to your DAC, bypassing the OSX System Mixer. When setup correctly you should see a lossless signal path similar to above.

More on Exclusive mode here:

I just checked it, streaming from Qobuz with volume leveling on - no clipping at all.
It’s got to do with your individual setup, quite likely!

I integrated the song’s dynamic range and accumulated its peak levels and frequency distribution.
It’s got a lowish dynamic range of 4.9 loudness units (top middle).

You can also see in my graph’s accumulated peak value (top left), that Roon indeed applied -5.1dB volume leveling as indicated in the signal path.

1 Like

What program are you using to analyse the track?

.sjb

See this post …

2 Likes

If you’re on windows you could also install virtual cable for signal loopback, then pay for DRMeter

2 Likes

Thanks to you all for your support & suggestions! Excellent…

and the pics show where the various settings are hidden - at the very least I’m learning my way around :grinning: that dot on the player wasn’t too obvious previously

so yes I had Core audio and exclusive enabled (defaults?)

Screenshot 2023-05-09 at 18.20.03

Not sure why Roon is upsampling and downsampling?

Is that controllable?

Although I have a few 24bit / 192Khz albums. I checked these (Gotan Project) are really 44.1kHz 16bit

I make the upsampling conversion ratio 4.3537415 which might not consequently be bit perfect?

Pine player says it is upsampling to 176.4kHz (32 bit) a factor of 4 exactly ( I seem to recall setting it to integer upsampling in the past?)

Just arranging to use one of my kids family Tidal - will try (but wondering whether that’s likely)

Your DAC maxes out at 24/96 that is why Roon is down sampling.

From the manual of the Audient iD14

DIGITAL INPUT:
8-CHANNEL ADAT: 44.1kHz to 48.0kHz
4-CHANNEL ADAT: 88.2kHz to 96.0kHz SMUX
STEREO S/PDIF / TOSLINK: 44.1kHz to 96.0kHz (Stereo)

1 Like

Control it like this:


Instead of asking all beginner questions in the forum, you could browse Roon’s helpcenter here

Sorted!

thanks to all

Sorry if they’re newbie questions.

The difficulty with many “help systems” is they’re much easier to use if you are familiar with the terminology.

I was at one point a long term Excel user - who got asked many how-to’s for that reason. I could always find the right part - because I understood the terms and jargon. (it’s been a while since now… I’m not offering :disappointed_relieved:)

It had seemed like a conversation where I worked through the possibilities (with much help)

1 Like

Really didn’t mean to offend you with my last comment!
But I feel things are often better explained in the helpcenter, instead of truncated, sometimes misunderstood feedback from users.

So tell us, what’s been the issue?
Maybe others can benefit when reading…

By definition, no up-sampling is bit-perfect, regardless of the ratio. Also, whether the ratio is integer or fractional doesn’t affect sound quality.

Sorted - I changed, per Marin’s diagram above

  • the sample rate conversion to “Max PCM rate (power of 2)”
  • and also the sample rate conversion filter to “Precise linear phase”

thanks :+1:

Have you satisfactorily resolved your SQ issue re: Roon .vs. Pine Player?

Yes - sorted

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.