Why is Roon broken so much since 1.6

#44

It’s better without Qobuz but still gets some issues.

(Richard van Enteren) #45

I have the same problems but never replied here and also appeard after the last big update. Never had problems at all and I’m using Roon from day one. Hope there’s gonna be a fix very soon.

1 Like
#46

1.6 was working great for me from day 1. (I do not stream)
But in the last few weeks roon has slowed down, randomly quits and is very sluggish.

No changes in my set-up…

I hope something changes soon.

1 Like
(Jeff Young) #47

I started experiencing very slow searches with 1.6. While I have a Qobuz account, I only use it for purchases/downloads, and not streaming. So I turned it off in Roon and my search speed is back.

However, when Roon gets more deeply integrated with Qobuz (ie: when I can initiate buying a suggested track/album from within Roon), I’d want Qobuz integration back on…

(I am in Ireland with a Qobuz account opened from Ireland. My internet link is via radio. At the moment I’m getting 40M/s download speed; 4M/s upload. Roon core is on its own box, running ArchLinux on a 7thG i5 w/ 1TB SSD.)

#48

Not sure how you get there. Still streaming across local network, only nothing coming in via Internet and hence no lags caused by Roon’s cloud servers.

(Martin Webster) #49

You’ve eliminated the entire Internet and everything works now, so the logical conclusion is that Roon is responsible for every connection between their servers and yours?
No, your test is flawed and so is the analysis. There are many variables at play here and the changes released in 1.6 are exposing issues that were previously hidden.

The issue is more likely to be local.

(Dan Herrmann) #57

I have Roon Core running on a Windows 10 PC with 32GB memory (i5 quad core). Running Tidal.

Just did a search for Elvis Costello - took 2 seconds.

(I have about 3000 CDs in my local library)

1 Like
(Shawn Costello) #58

I’m at work but have you tried clearing Roon’s cache. I forgot where it’s located. I did it a year ago. I’ll check when I get home.

(Vincent Kennedy) #59

@Dan_Herrmann - Hi Dan, after you did the search did you click on the result to see the performer page? What I have been experiencing is slowness there. Loading the actual page with the Performer’s top tracks, albums, etc have been very slow. Interestingly, the search is faster on my PC then it is on my cell phone. I need to test with my Wife’s phone and another PC, to do further validation. Unfortunately I haven’t had time to dig into this issue lately.

(Eric Stewart) split this topic #60

4 posts were split to a new topic: Cannot connect to Roon on QNAP TS-451

#64

Well this is not getting any better and is very up and down. Last night at one point it took over a minute to display results. The odd thing I looked at the logs, whilst I am no expert I could find the time I did the search when it was slow. According to the logs it returned the results of search in about 42ms which is bugger all. No sign of any delay at all mentioned. Yet when performing search to display the results on the remote client which this time was Windows 10 pc it tool about a minute. It was that long I gave up and started to make a post to support. Make of this what you will but during this lag I could use other apps search using TIdal and Qobuz apps with no issues, So to me something is wrong with Roon. Whether its the server or clients I cant say but something is not well in Denmark and I dont believe its my network . Some of you may not be experiencing this issue, great you are lucky but it does not mean its not happening or an issue for others.

1 Like
#65

I experience the same issues with the latest Roon version. Searches (and searches when manually tagging) may take up to 2 minutes (!!). But then there are times like now where i experience no lags. (6.30 am MEZ).
I know from other programs I use for my job that the issue is not my internet connection.
I have a very large local database and Qobuz and Tidal connected as well. That “search problem” is with my local database as well as with Qobuz and Tidal.
@CrystalGipsy description of the problem is exactly what I experience.

2 Likes
(Rune) #66

I am experiencing the same thing here in Copenhagen. It sometimes can take a minute to display the search result. I also do not believe it is my network. The core is cabled and I have a 1Gbit cable connection and the Speed test link in another thread gives me over 500mbit download so probably not the internet connection as well.
I use a iPad Pro so it could be the Roon remote app that has a problem. The speed test run from the iPad is over 200Mbit.

1 Like
#67

Also I was experiencing very slow search, opening album pages, adding a Qobuz album to library etc. which all started with Roon version 1.6. It didn’t matter which Roon remote I was using (iPhone, iPad, iMac).

I use a Nucleus+ and have a fast and stable internet connection. I use Qobuz, but not Tidal.

My router was set to use the Google DNS address 8.8.8.8. Today I deleted this address from my router settings and let the router use a DNS address assigned automatically by the internet provider.

All of a sudden searching and navigating in Roon is snappy again, on all Roon remotes, at least in the last 30min since I changed the DNS settings.

I don’t have an explanation for this change in behaviour, but at least wanted to share my personal experience.

(Dom) #68

Maybe it worked because you probably restarted Roon Server.
I have the same Problem Roon on Nuc can get extremely slow since 1.6. search of internal library can take forever. All in all performance very sluggish.
Then I restart Roon Server and all is perfect again - well, for a couple of days… So it seems to be a Roon issue and not a Network issue. Cache or something like that?!?

(Vincent Kennedy) #69

“It’s not necessary to flag @ support in all new Support threads. It creates unhelpful flag clutter. Support staff see all new threads in the Support category. The flag is helpful to identify exceptions where a post falls through the cracks.”

Good to know. Thanks.

1 Like
(Vincent Kennedy) #70

@mike - while I agree that the slowness issues can be a local to user issue. I still standby the fact that the same searches directly in the Tidal or Qobuz native apps are very fast in comparison to the same searches within Roon. Same network, same computers/phones, etc. I went so far as to patching my PC into the same switch that my ROCK is connected to and ran the same searches there vs my prior wirelessly connected tests. I had the same results. Roon searches are much slower.

To be clear, when I state “search”, I mean after using the search function, clicking on the result and then going to the Performer page. Once at the Performer page, the content there on the Performer page is slow to load.

#71

This is the ladder (or whatever the Gold standard is called). Not only that the Qobuz or Tidal apps perform within a second on search requests, apparently with most users that have problems with the 1.6 search in Roon, but also in all 3rd party apps that have integrated Qobuz or Tidal SDKs it work fast and flawless, only Roon sucks at the moment. I hope Roon finds their bugs in implementation soon and gets back on the level of all others fast. It‘s not about strange network configurations in users networks but on wrong implementation from Roon side.

3 Likes
(Angus Doe) #72

I’m having similar issues too, very slow searches and also slow to stream/start stream and also slow to add to library from Tidal or Quobuz. Only just added Qobuz.

I have a 200Mega bit broadband download speed.

Before 1.6 performance was good from my Mac Mini core and NAD M12 with BluOS.

I do hope that a software update fixes this!!! It’s starting to turn me away!

(Ricardo Higgins) #73

I have not gone to 1.6 due to the slowing issues. I’m happy at 1.5!

1 Like