Wi-Fi Adaptor (Dongle) Set-Up

I am struggling to set up my RPi 3 with a wi-if adaptor. I am using an Edimax AC600, which is one of the supported adaptors. When I select it during the setup process, scan and select the Wi-Fi network and then reboot, the adapter just blinks steadily and the unit never shows up on the Roon network. Nor does it show up on the Devices page from one of my other Ropieee devices.

In case I am being obtuse, could someone run down the process from flashing a new SD card through selecting the Wi-Fi adaptor and getting it running in Roon? I feel like this should work but it is not.

@spockfish, here is the feedback file for my unit. Maybe something pops up usefully here. Thanks for any aid you can render.


Hi @Lanny_Hoff,

Thanks for your feedback. This took me some hours to figure out, because this is one of the dongles I have myself and for me it works.

But this morning I realised the difference: you’re running a Pi 3 and I tested this (again) on a Pi 4.

So the good news is that I can reproduce your problem on a Pi 3. The not-so-good news is that I haven’t found a solution (yet), but this has my full attention.

I’ll let you know as soon as I’ve got a fix for this.


Thanks, Harry. I will continue to dink around with it and the order of operations as you grind on a real solution. If something works I’ll let you know.

BTW: I am hoping to deploy this WiFi adaptor on a total of 5 Ropieee units in my quest to stabilize my system and a last-chance effort to avoid wiring our house. All but one of my units is a RPi 3.

I’ve got a solution in the works. I hope to release an update to the beta channel somewhere the next hours. Would be great if you can test it.

I would be happy to. Thanks for your work on this!

Hi @Lanny_Hoff,

I’ve pushed an update to the beta channel that solves your problem.

For switching to the beta channel you need to go the the ‘advanced’ tab in RoPieee’s web interface and set ‘Update Channel’ to ‘beta’. Next follow instructions (it will reboot, and then tell you that updates are available which you should install).

Let me know how it goes.

I installed the beta update, selected the Edimax AC600 Wi-Fi adaptor, and chose my Wi-Fi network. It worked immediately. It boots up and finds the network faster than it did when I was attempting and failing to make it work. From my perspective, the fix seems to have worked.

For a data point, I grabbed another RPi and a different adaptor that I have tried in the past (Realtek 8812AU/8821AU) to make work with no repeatable success. I applied the beta update, turned Wireless off and on again using the ADVANCED dashboard and the adaptor showed up immediately. Now that unit seems to be running fine as well.

Finally, I have applied the beta update to a third unit and installed a new Edimax AC600 adaptor. It updated and worked very smoothly. All three units are working so far as I can tell.

Thank you for the support, Harry. It is much appreciated. I am hopeful that I will have finally achieved a stable network with all my endpoints.

Thanks for testing!

You can switch back to stable if you want.
Nothing happens, until the next stable update.