Wifi disconnects when starting Roon Remote on Android

(Marcel van Tilburg) #1

Since two weeks my Android tablet (Samsung S2) loses wifi when starting Roon Remote. when I try to reconnect, it says ‘authentication error occurred’ and I have to reboot to get wifi working. This happens with both the wifi access points in the house (2.4 and 5). It all used to work flawlessly and it still does on my Samsung S6 phone. I have sent my tablet to Samsung for repair and they returned it saying no repair was necessary. Otherwise wifi works perfectly on the tablet. I can do everything including streaming HD movies for hours without any hiccup. Then start up the Roon Remote app and it’s gone. It is driving me insane. Are there additional settings to be made in the router? Or in tablet? Or in Roon Server? Please help!

#2

Who knows, you’re not providing much information about your hardware or settings, aren’t you?

A good starting point may be to login to your access point and check the logs there for errors.

(Roel) #3

I had similar issues when i was using a Tab S2, but it was not exclusively to Roon. At random moments the tablet would lose the wifi connection. After searching on the internet it was an issue with this tablet and its software but there was no real solution. The Tab S2 was the only device in my house that had these connection issues.

My solution was to ditch the tablet and now i use a Chromebook/tablet and that works just fine.

(Marcel van Tilburg) #4

Many thanks for your advice! After a few more hours of frustrating experiment, I have come to the same conclusion. Shame Samsung doesn’t admit this! I will go out and buy another tablet today, not sure which one it will be…

(Daniel Beyer) #5

Not all Tab S2’s have your issue. Mine has been and still is rock solid. I have it on 2.4. Maybe try uninstalling and re-installing Roon on the Tab.

Do you have any remote or vpn programs on that Tab S2?

(Marcel van Tilburg) #6

Thank you, Daniel! I have no VPN or remotes on that tablet. Crazy thing is that it used to work fine, with only occasional wifi dropouts after which it would reconnect quickly by itself. I think the real problems started after a software update by Samsung, but I am not completely sure. Anyhow Samsung said they had installed even newer software, unfortunately to no avail.

I solved my problem by buying a Huawei M5 MediaPad, that is a dream to work with: faster, wider screen (giving room to more covers!) and not a single wifi dropout. Detesting both Windows and Apple I found that there wasn’t much choice compared with a few years ago, but I am quite happy with the Huawei!

3 Likes
(Andrew Callum) #7

I am having the same problems with a Samsung Tab2. Has worked for over a year flawlessly, then as described above it causes the wifi on my device to crash. I can’t use it as a Roon remote anymore. It works flawlessly otherwise. A Roon update must have created a problem?

Any ideas, other than buying a new device would be appreciated.

My Samsung Galaxy S9 phone works fine.

(Tim Fontenot) #8

Same problem with a Samsung Tab2 that started about 2 months ago. Frequent WiFi connect issues that completely lock up WiFi for other apps, get “authentication error” on the Wifi settings page. Closing Roon then turning WiFi off for a minute then starting Roon again will eventually work, for a random amount of time. Deleted Roon from the tablet and reinstalled, did not help.

In case anyone is looking into this issue, all other apps work fine, meaning that if they are experiencing short WiFi drops they are at least recovering, Roon is the only thing which crashes the wifi. WiFi signal strength does not seem to be an issue, trying to connect close to my Eero router doesn’t work better. If Roon does happen to be running okay and the tablet screen shuts off or I close the tablet cover Roon will definitely hang up and crash the wifi.

I also have Roon on a Samsung phone, which does not seem have this problem, but really don’t spend any time using that as a remote.

(Bart Maguire) #9

I have the same issue with a Samsung tablet S2.
Only happens with Roon Remote, everything else works fine.
Turning it to Flight Mode and back resolves it, for a random amount of time.
Tried uninstalling and reinstalling Roon.
Everything else on the network works as well as it ever did and Roon Remote works on on other devices.
Started about two months ago, after a Samsung update.