Wifi not connecting

somehow the wifi on my raspberry pi4 is not connecting. I can select the correct wifi and fill in the password just fine, but after a reboot it still only works over ethernet. I sent a log with the identifier 77a9e5cc7ad74da5 hope that helps to sort out the issue. Maybe it has something to do with my router settings, all other devices in my network work fine though. I use the onboard wifi atm but I am willing to buy a usb adapter if it’s not possible to get the onboard one working.

I assume that this happened with the latest update of Ropieee? In have brought up this problem in this thread and @spockfish has confirmed that this is related to the new Linux kernel and that this will be fixed in next release.

I saw your comment but wasn’t sure if this is related to my problem as I’m using the integrated wifi and can actually see the wifi network, just somehow not connect to it. I’m on the latest beta, maybe the upcoming version will fix it for me

No. The upcoming release fixes an issue with external USB adapters.

Ok thanks @spockfish. Any plans to fix it in the near future? I’ll be happy to help with testing if that helps you

Sorry, I didn’t recognize that you referred to the internal Wifi of your RPi. Apparently I have been a bit too enthusiastic. :wink:

Don’t know if there’s anything to fix with RoPieee’s set up of a Pi’s internal WiFi. My Pi 4B works very well using the current RoPieee stable version.

I’d suggest you look at your side of this issue… Is the 5 GHz signal strength enough to have the Pi connect? have you a second SSID on the 2.4 GHz band? Could you connect to this? Is your DHCP set up right on the router? Have you tried to reflash the card and try with a pristine copy of RoPieee to set up WiFi?

I’ve already tried everything you suggested with no success.

Maybe it’s a hardware problem…

I will temporary install the pios on it to see if the wifi works there. That way I know if it’s a hardware problem but I don’t think it is

I’m having a similar problem with several Ropieee units. I have my units set to reboot weekly or daily. One of them that reboots daily rebooted and now neither internal nor external wifi works. It works fine with a direct ethernet connection.

I rebooted another one of my units just to see what was going on and it stopped working with wifi as well. I reflashed with the current release and it starts up but wifi no longer works. I have tried to reflash with the last stable release, which worked fine for me, but unfortunately Ropieee updates on start up so I can’t test that approach.

The last two reflashes have resulted in a failed installation. I’m not sure what’s going on but it appears to be catastrophic.

Do you have the latest image downloaded?
Wireless external has an issue (in some cases, depending on the unit), but internal should just work.
But if you reflash make sure you use the last available image.

Ok I could connect the pi with a wifi hotspot from my phone, so it’s not ropiee that’s causing the problem but my router config. I don’t know what to change though as all my other devices are working just fine and there are a ton of options

1 Like

EDIT: The last unit I reflashed with the most recent image is no longer working using internal wifi.

Reflashed with the latest image and the unit appears to be working on internal wifi. I’ll roll out the next update manually to make sure the external wifi aspect is working properly.

Hi @David_Schlicht,

This might be a RoPieee thing, because I’ve found an issue with deciding on the proper region.
That can influence your wifi. I’m going to release an update tomorrow. If you can’t wait you could switch to the beta channel.



Recognise your frustation. I never had any luck with Pi’s internal WiFi. Ropiee works fine with my Allo and HiFiBerry end points via the Allo supplied USB dongle. You seem to need a specific kind of chip set for this.

Cheers, wim

Have you tried a WiFi extender locally then connect Ethernet with a patch cable could work.

I already use a wifi extender, the signal is emitted 2m from my pi, so that’s not the problem. I will get a usb wifi adapter if i can’t get the internal wifi to work with my router

Does the adapter have an Ethernet port?

If it does you could use it to troubleshoot the WiFi component of the pi , by elimination.

I have not used my pi on WiFi so I can’t comment , on Ethernet never a blip. I would think the antenna of an extender may be better than the pi, maybe ?

FYI here are the specs of the dongle that works with my Pi 3B and 4B.

1 Like