WiFi Scan does not find G5 Network


My Netgear router provides 2 networks: One 5G and and one slower one. My RopieeXL endpoint (running on HifiBerry Digi) is connected to the slower network, but it appears to be too slow for streaming (I am getting frequent errors and skips) so I wanted to switch to the 5G one.

However, the scan does not find the 5G network and the UI doesn’t allow for entering the name manually. I tried putting the HifiBerry right next to the router for the setup but the scan still doesn’t find the 5G.

Any ideas for what I could try to fix this would be very much appreciated!


Are you saying that you have two SSIDs on your router, one for the 2.4 GHz band and one for the 5 GHz band? If so, can’t you put the 5 GHz SSID name and password in the RopieeeXL GUI and attach to the network?

Forgive the silly question, but which model Pi do you have? I may be remembering wrong, but I believe that the Pi 3 only supported 2.4GHz.

Thank you @Nathan_Wilkes Nathan, forgot to ask that. The 3b+ and 4 have been out for so long that I didn’t think about earlier versions.


I am using a RPi 4 Model B Rev 1.4 with HiFiBerry Digi2 Pro

When I hit “Scan” and then open the “Network” dropdown, my 5G SSID does not appear in the dropdown. Only the 2.4GHz SSID does.


I saw this on another forum regarding setting your country code so it can see the proper 5 GHz channels:


Might this help?

It might be useful if Harry has time to check the logs. Go to the Advanced tab and hit Send Feedback, and post the identifier here.

1 Like

Run a free WiFi analyzer app on your smartphone and check whether both bands show up in the smartphone first.

Don’t some routers combine both networks under one SSID then devices connecting automatically jump between the two depending on signal? This too can sometimes cause problems.

Can you check your routers settings and see if you can create two separate SSID one for 5 and one for 2.4

I did a quick search on internet for Netgear, Separate 2.4 & 5, image below shows what I am saying,

2.4 should be more than adequate for streaming Roon in my experience, you may be experiencing other networking issues.