Wifi Signal Quality monitor

Hi,

So had an odd thing happen. I live in a Wifi congested area. Even 5 GHz is hard to find space on sometimes. Last night before gaming I checked and went from a mildly congested channel to one completely empty.

Since then my music sounded much better. I forgot I had done the channel switching, so I thought maybe it was a recent upgrade.

So, here is my question, without wanting to sound like a crazy audiophile. Is there anyway to monitor the signal at the bridge and have it tell me there is excess Wifi jitter, or errors or whatever? I’m not sure if Roon ever starts to throttle the bit rate, but if that happens, notice that it’s happening would be good.

One idea is to understand how many times the buffer is empty or near empty. Like, if it’s 100 mSeconds, but it often reaches 20, that’s a good sign a larger buffer would help, no?

I guess what I’m looking for is something more specific to Roon than merely wifi signal quality. Something that says “Hey, I’m not getting the data I need in time, and it’s causing the audio to suffer.”

I’ve forced my WLAN to an empty channel too, definitely helps. Two thoughts:

  1. I don’t think Roon is interested in adding “stats for geeks”
  2. Routers can often display the WLAN rate of a connected device

One other thing here…audio over wifi unless you have no other option is less than perfect and the higher the bitrate the less effective its going to be. For control its not an issue.

1 Like

Just to be pedantic, can we call it audio “data”, as its not audio at this stage? I also don’t quite get how streaming 4K Netflix over WiFi is fine, but I might have problems streaming audio?

1 Like

the content is audio - of course the transmission is data. Its all about effective throuput.

I doubt this feature request will get much traction in dev terms as there are adequate wifi monitoring tools for different platforms and even ones that can seek out AP’s and transmission rates like iStumbler

It might surprise you how many wifi devices you have with SSID’s in your house…ie I have Chromecast ones and Arlo security cam ones that are just there (not created by name) well as my lan network ones that I manage.

The answer is the buffering behavior of the endpoint.

When streaming video the endpoint usually holds a large buffer and plays off from it. If the data stream speed is inconsistent but you still manage to avoid buffer underrun you’ll not see any video skipping.

I don’t presume to understand Roon’s data streaming protocol, but if the buffer is small by design, and there are reasons for keeping buffers small, then you’ll hit buffer underruns and audio skipping.

You didn’t describe you audio chain, protocols, etc. I know that if the endpoint is squeezeslave, you can adjust the buffer size to hold a few minutes in memory.

OTOH, there’s an old thread here regarding playing from memory. I didn’t read through the thread, but I remember there was a lot of subjective opinions for and against this.

Buffer Size is something you have some control over in Device Settings, click Show Advanced

WiFi is a beast. The usually available signal strength meter doesn’t tell you anything about the connection speed or quality. Using old(er) devices in the same network might degrade the throughput of the whole WiFi cell (affects all connected devices). Roon Core, Control and Endpoint are also constantly communicating, pushing the demands on connection quality above what’s needed for other simpler streaming applications. Even a short interruption in communication may lead to “Roon Lost Control of the Audio Device”.

This is a nice utility - it scans all near WiFi access points and displays various stats.

You may be able to deduce the best channel for your setup.

I mentioned iStumbler but no link provided… this is Mac workable https://istumbler.net

You know, this doesn’t necessarily have to be a visible guage, it could also auto-bump up the buffer size. Maybe you get an alert instead:

“Roon encountered network issues so it has bumped up the buffer size to 250mSeconds.”

There are lots of tools to do this. The Android tools are better.

I find that the “automagically” setting has a tendency to drift to the same channel everyone else is using over time. So, you find a, mostly, empty channel and all your neighbors follow after 30 days. Then you have to go move it again. Good to keep an app for scanning on your phone and just look every month.

Yeah, I know, I have android tools for this, as well as a PC and Mac OS version. I don’t want to be looking at them 100% of the time, plus, while I can tell that right now maybe this channel only has 1 other router on it, that doesn’t mean it will be true in 30 minutes AND, most importantly, it doesn’t tell me what the actual effect is.

Having some sort of gauge from Roon telling me just how close to empty, or how many times, the buffer was is a much better indicator of audio quality suffering.

(First, I should mention my fondness for Eero, especially because it doesn’t offer selection of WiFi channel, or any other configuration. I love that, don’t want to manage my infrastructure.)

But I have an interesting issue that may be illuminating. At the moment, I’m listening to my Chord Hugo 2 with new 2go, over WiFi, and I get occasional hiccups. But for the last month I have been getting those same hiccups when playing on the main speaker system, which is all wired. Even when playing local content off the internal SSD in the Nucleus. Strange. There is a wired network between Nucleus and the Meridian, I’ll try the USB connection,

I mention this just because these hiccups are a new phenomenon and we always blame WiFi, or at least the network. Seems there may be something else going on.

EDIT No, dammit, I still get hiccups with no network involved. Ok, I’ll move this to another thread. Just thought I’d mention it, it isn’t always WiFi.

That’s odd I don’t have buffer size option listed.

Right click on device.

Device Setup

Show advanced

Buffer SIze

All the other options but Buffer size. I have an AURALiC Aries and Vega DAC both are Roon tested.

Maybe this is device specific?

I’m using the Roon for ARM software and a Raspberry Pi 4 as the streamer with Ubuntu 19.

I believe roon tested or ready devices set that when they handshake with roon as part of the set up.