Will Roon work on new QNAP TVS-873 NAS with 16GB Memory?

QNAP TVS-873 16GB 32TB (8 x 4TB) 8 bay NAS Integrated with HGST Ultrastar HDD (Enterprise)

HDD Config: 4TB - HGST Ultrastar HUS744020ALE640

AMD R-Series RX-421BD quad-core 2.1 GHz processor, burst up to 3.4 GHz

Embedded Radeon™ R7 Graphics Processor

Please let me know ASAP of Roon will work with this configuration as I have ordered this NAS and have stopped shipment so that we can make changes to NAS if required to run ROON.

Roon’s recommendations for a NAS are here.


As a minimum you should add an SSD for the Roon database. However this NAS may still be under powered.

A lot depends on your library size and if you are going to using high res files and or doing a doing a lot of DSP, more of which is coming with soon 1.3.

Let us know about those things and I’m sure others will chime in with some thoughts.

I am in a chat room with QNAP now and your Roon Website:


Please look under “Roon core servers”

your site says "Roon Core devices are music servers from our partners which include Roon Server pre-installed or available as an installable option.

With any of these products, you’ll be able to enjoy Roon without a PC!"

And the QNAP tech has never heard of Roon Labs

The QNAP Tech Said “Yenhsing Chen:
I see their website saying that QNAP pre-install Roon server inside. I have being working here for almost 4 years, and I just asked all tech. support here. We never hear of it. And cannot find their apps in App Center. There must be some kind of mis understanding there. For example maybe roon server;s qpkg for QNAP is not ready yet or something else. How QNAP work is lik… We have an App Center in our web interface, which allows 3rd party to put their apps into it. It works like apple store in iPhone. You may need to check with roon server developer to see where they put their qpkg and so on.”

The NAS is a large investment for me and I really want the Roon Labs Product to work very well now and into the future! I do not have the NAS but am ordering it primarily to be a media server and really like what I see of your GUI!

Hmm that is rather confusing. My understanding (I’m just another user trying to help by the way and nothing to do with Roon other than that.) is that the QNAP does not come with Roon pre-installed and you need to download and install it yourself, but maybe that is changing.

Lets ask @mike and @crieke to see if they can provide more details.

In the meantime see this thread and the links in it for more details. Again note the recommendations for a top of the line NAS with an i3 or i5, though Roon will work with any 64 but intel CPU.

Let’s drop a flag for @robdarling and see if he can clarify QNAP appearing as a Roon Core Server partner.

I can’t say for sure, but I guess this might only be true for third party dealers, who do custom configuration and offer a hardware setup and software (=qpkg) installation that is preconfigured for RoonServer according to the customers needs.
As far as I know QNAP NAS do not come with any software preinstalled (except their QTS operating system and maybe some QNAP apps.)

As the Roon Labs specifications call for Intel I3-7 processor, that’s what I bought. Today I am familiarizing myself with QNAP TVS-871-I7-16GB, 512GB Internal SSD with five 6TB drives in RAID 6 configuration (after overhead a little over 16TB for music & videos and internal 12TB future expansion capability). I purchased the lifetime Roon membership. Perhaps in a few days I will have the knowledge to install it and start using it. :slight_smile:

Hi Bill,

If you haven’t already come across it, the online Roon User Guide can help reduce the learning curve.

Thank you Andybob. To be honest, my spare time right now is consumed with ripping cd collection to new QNAP NAS. But soon enough I’ll have it ready for listening enjoyment.

I have recently purchased a TS-873, upgraded its RAM to 24Gb and installed Roon on an internal SSD.

It works perfectly and very smoothly. I do not use the DSP functionality at all though.

I have Bliss installed on the other SSD and so have a perfect system :slight_smile: I dump files into the Music volume wherever I want, Bliss then organises it for me and Roon makes it available for lossless streaming.

Very pleased

1 Like

I have the TVS-473e here as well with the same CPU. Runs very well. If you would like to see a screenshot of the signal path with some specific dsp, let me know. I have to put my gear now into boxes, as I am moving to a new flat. (So I can run tests for the next 1-2 days).
I did not had the time yet to do a proper benchmark.

I’d be curious to see your signal path

I still have the TVS-473e with the default 4GB Ram installed. The device was a little bit picky when I tried to install 2x16 GB third-party Ram modules…

This is playing DSD64 Material to the Bluesound Pulse 2.
(CPU: AMD R-Series RX-421BD)

Here the same with the TVS-471 (which has been manually upgraded to an i7-4790T cpu):

Crieke have you tried one stick of ram at a time and checking to see if it would boot? You might have just received a bad stick (if one stick at a time works RMA stick that doesn’t work)
If one stick at a time doesn’t work then send me picture of your original ram, then your upgraded ram. Make sure picture includes the stickers with information printed on them could be you bought RAM that was too fast for your application too slow isn’t usually a problem except it’s slower :-0
post here if you can if not my email is my “first name at my last name dot ca”
For others always go here

many memory manufactures out there Kingston has never let me down in 20 years of computer experience.
for NAS’s put make and model number to find compatible memory. When building PC’s use the drop downs to find my company name/model etc.
If in Canada go to www.shoprbc.com contact his guys they support chat and email.
Been dealing with him for exactly 20 years this month.

1 Like

Yes, I tried that. I also removed the factory RAM (as suggested on posts in various forums).
I tried 2 different models of Crucial Ram modules. (2x 16 GB DDR4 PC4-19200 and 2x 16 GB DDR4 PC4-17000). They both caused the system to not boot anymore. After that I was a little bit tired as the online shop was quite slow in sending the other rams and also in processing the returned items (with both Rams).

Will try again with Corsair, when I moved to my new place and have everything set up again.
Thanks for the recommendation.

If you are adding 4 sticks it can help to if they are from same company and same speed. So I went for two more 4gb stick from Kingston to get to 16gb. I do not run virtual machines or use as a computer tho.

Note: The maximum supported memory is 64GB.

For one SODIMM module, insert memory into slot A2 or B2.
For two SODIMM modules using dual channel, insert memory into A1 and A2, B1 and B2,
For three SODIMM modules, insert memory into A1 and A2 and B2 or B1 and B2 and A2.

Interesting the user guide does not have same information as Hardware installation guide on installing memory.

I tested if you choose A1 and B1 you only see 4gb. If it doesn’t work next time try your 2x4gb in A1 and A2 try you two 8’s in B1 and B2.

Thanks for the info. I inserted both in the correct sockets and (if I remember correctly), the TVS-473e is more picky with the 16 GB modules. Currently I cannot do anything as my equipment is in boxes and I can’t use Roon or the QNAPs.

yes seems you have a newer unit denoted by the E. Mind if I leave it up?
Seems Roon runs fine on my TVS-873 with 16gb other than indexing no major spikes in CPU usage. Have had three apple tv’s on at same time playing three different sources from NAS (I use 2 of 4 NIC ports to a switch). Each file was 24/96 or higher so would need to be down converted to Apple tv.

Have built my J3355 based system, just need to install windows, so hope to hear a multi channel 256dsd file for the first time this weekend. Will report some actual CPU and memory usage numbers when I can add its playback to three other devices.

BTW: Seems my 4k Apple TV plays 16bit by 48 not 44 as reported.

Here is a picture of resources on my TVS-873 streaming two DSD 64 5.0 files to two PC’s as Bridges.
Then three different 24bit audio files streaming at same time to 2 apples tv’s down converting to 16/44, the third a 4k apple tv so 16/48. Not even rasing a sweat.

In a separate test.
I tried a DSD256 5.0 file and it stopped after a few seconds. So moved file (2.1gb for 5 minute song) to my M.2 drive. It played for a minute before stopping not sure if limitation is CPU or Network speed. Looks more like network speed but conjecture because I don’t have a 10GBe network to check with to confirm. For the DSD256 5.0 file I did stop all other network streams via roon, DLNA (Asset), PLEX. My 4 1gb NICS are trunked together using a managed switch.