Win10 Corrupt Folder

Hi All,

/Volumes/MP3 Rips/Bill Nelson/Stand By;Light Coming

I have the above corrupt folder on my Win10 core, no file content, which I have not be able to remove. I’ve tried everything I can think of short of reformatting the drive with no success.
I don’t particularly want to buy an app for a “one off” problem but that said your thoughts/solutions would be welcome before I resort to reformatting the drive.

Thanks in anticipation.

I’m not a computer guy, but maybe open Windows in Safe Mode.

What is the error you’re getting when you try to delete? Have you scanned the volume for errors?

Thanks Jim, will have another go…it’s be irritating me for months… :+1:

Typical error messages when trying to access the folder or change it’s attributes…

This may not work, but it’s worth a shot. Back in the Windows 7 days, we had a registry hack called ‘take ownership’ on the context menu. I can’t remember the background to it, but I remember it being helpful when creating ‘unattended’ setups.

If allowed; download these two files, which are registry edits. One adds it, one removes it.

Double click to install, and follow the prompts. Then go to the folder, right click and use take ownership. See if the folder can then be removed.

Next would be to check the disk. Use: “Chkdsk D: /scan /F” fuction to check for errors. Guide here: What Is CHKDSK & How Does It Work | All Details You Should Know

If nothing else works, back up the drive to the PC or another drive, and format it.

Try FileAssissin by Malwarebytes. I’ve used it before and it did the job. It’s a very lightweight program and free.

Start with chkdsk. If that doesn’t fix it, you can try to take ownership of the directory without any registry hack. I’ll send you the command if chkdsk doesn’t work.

Thanks for the suggestions all, I’ll take a closer look tomorrow when this evening’s indulgence wears off.
That said, the chkdsk was tried a few weeks ago and didn’t resolve the problem :wink:

It doesn’t seem related to security, but if you want to try to take ownership of the directory, start a command prompt as administrator and run the following commands:

cd /d "D:\MP3 Rips\Bill Nelson"
takeown /a /f "Stand By;LightComing"

Then you can try to delete the directory:

rd /s/q "Stand By;LightComing"
1 Like

Boot into safe mode and retry the CHKDSK.

Also try the GUI-based approach: right click the drive, Properties → Tools → Check.

A wild guess, however unlikely this may be: another process locked your folder. Make sure you’ve stopped Roon and any other music software or tools.

If you’re familiar with Linux, you could also try mounting the drive in Linux (via a bootable Linux USB thumb drive, or a Linux computer) then force delete it.

Result is “error… can’t find the file specified”

Thanks, tried fileassassin but it fixes files only & can’t deal with corrupt folders unfortunately :confounded:

Tried all but the Linux options (I’m mainly a windows user) but no success.

I have given up, dismounted the drive and set off a reformat, 2TB so it’ll take a while.

Thanks Peter (And everyone else) for your suggestions.
By coincidence my U2 mini arrives this week, I may be in touch :grin:

1 Like

You can do a quick format BTW, it should take seconds.

1 Like

Thanks, Interestingly the drive wouldn’t offer a quick format so I started a full (slow) format which failed at 26%. When I attempted a second time I was “offered” quick format which then worked.

I now have to copy 164 GB of files across the network (while sleeping)….:+1:t4:

1 Like

If full format fails, chances are there are bad sectors in the disc, which can explain the corruption. You should try full format again and if it keeps failing, you may want to replace the disc. The elevated command prompt is your friend here. To do a quick format:

format D: /q

To do a full format, remove the “/q” switch.


That’s very unusual.

Download a free HDD SMART report tool, run it and post its detailed report with raw values or PM it to me.

I agree with @Marian. It sounds to me like a failing hard drive. You might want to look for a replacement.

Output file sent via pm. :+1:t4: