Win10 NUC can't see USB optical drive

Hi all. I have a Buffalo USB optical drive that works plug and play on two Windows10 laptops, a MacBook Pro, and a Windows10 desktop. I thought it would be a piece of cake to hook it up to my NUC7i7DNHE running Roon on Windows 10 Pro and use it to rip CDs, but I can’t get the NUC to actually use the drive.

EAC tells me there is no CD in the drive; win explorer identifies the drive and appears to mount it as drive E:, and even shows the right number of tracks, but Windows Media Player won’t play it or identify the album. By comparison, the drive immediately works (with the same CD) using EAC, when hooked up to my other Win10 desktop.

I have tried updating the drivers through Device Manager – no newer drivers are found. I’ve uninstalled and re-installed the device and updated Windows, with no change. I’ve searched Buffalo’s site for an update and while they do have a devices download, Windows doesn’t seem to recognize anything in it as a driver.

I’m mostly a Mac guy and haven’t been deep in Windows hardware for a long time. Am I overlooking something obvious? Seems like this should be easy, so I’m stumped. I’d appreciate any pointers here, as I’ve tried everything I can think of.

The only time I’ve had trouble with a WIN10 program recognizing a CD drive is when that drive was on a passive USB hub. How is the drive powered, off the USB connection or separately?

Probably not what you’re doing, but FWIW.

Thanks for the thoughts. It’s powered by its USB connection. You got me wondering if the NUC didn’t send enough power through the single USB, so I also plugged in its other connector – no change, though. I’m pretty stumped.

There is no Roon ripping logic. There is a Nucleus(+) or ROCK ripping logic/possibility but the OP is using Win10.

Maybe anything of this might be of help:

Yeah, you’re right of course. Should have realized that.

I read the OP’s complaint to be that Roon couldn’t see the drive, so he couldn’t rip CDs.

Where’s my coffee?:sweat_smile:

Thanks for that pointer. The device properties in Device Manager actually says it’s working fine, so I don’t even have a useful error to go troubleshooting with. ¯\(ツ)