Windows 10 (newest update), SMB 3.1.1 and Synology

For those of you using a NAS for storage and mapping your drives it is important to note that in the November update for Windows 10, Microsoft has somehow changed their supported SMB protocol to 3.1.1 preventing one from mapping their NAS drives. I am not sure if this strictly a Microsoft issue or an issue for the NAS companies to address in firmware.

While I have yet to move over to Windows 10 for my Roon Core (or Server) and am still using Windows Server 2012 R2, I was playing around with a Windows 10 machine and after applying the November “fix/update” my two NAS disappeared from network and the Synology utility while recognizing the NAS could not map the drive.

The temporary fix I found, after driving myself crazy for days, resides on the Synology Forum.


Thanks Priaptor, that’s going to be very helpful for other users.

It’s a problem with some Linux smb shares and Windows smb3. Need to disable smb3 on the win machine should fix it.

I have no issue accessing my SMB3 shares on my Synology from the latest version Windows 10.

Have you done the latest November “fix” to it? That is what breaks the SMB 3 connections.

If you did that latest huge fix I would be curious if you did anything to enable your computer to see the NAS.

This has been all over the NET of people trying to figure out what happened, waiting for a fix from Microsoft, but in the meantime, as the link I posted in the OP reveals, a way around it by shutting down SMB 3 on the machine you are working with.


My machines are right up to date.

I can’t see the NAS in network neighborhood but I have no problem reading and writing to it using a UNC path. It has never not worked for me so I didn’t change anything.

Firewall is disabled on my W10 machines.
I don’t join a domain, I use local accounts only.
Fixed IP address with Google DNS servers.
The only package I have enabled on my synology is cloud station. A few iscsi luns.
No WINS server defined on the synology. Same workgroup name on the synology that all my windows machines are in. Encryption is set to auto and smb set to 3 on the synology everything else is the default values.

I am using link aggregation on the Synology as I have a Windows Server also set up with link aggregation.


I (as many others) can’t map our NAS.

I didn’t think of it but in entering the “folder to watch” I will just try to insert the network path instead of searching for it. When I try to map the drive that way no luck but I can get to the folders just can’t map it. Maybe l, as you said just entering the network pathway will do the trick.

Should have thought of that.

However are your NAS drives showing up under your netwotk?

My NAS isn’t showing up under my network places if that is what you mean? It did in the past, not sure when it disappeared I assume with the problem update you are talking about.

I can put \\diskation in file explorer and all my shares show up fine, I guess that’s why I never new there was a problem. And yes I always just type in my UNC path in my apps I never browse.

I never use mapped drives, not much need with UNC paths unless of course you like moving your data around and want the consistency of a drive letter that doesn’t change.

Ha, I’d been wondering why my Vortexbox wasn’t seen in the network. Fortunately it hasn’t been a problem as the network path entered for my watched folder seems to work ok.

I don’t appear to have any problems (yet) with my Synology NAS.

By the way, is a Priaptor a dinosaur who’s eaten too much viagra? :smiley:

1 Like

LOL, it is actually a handle from the very very very early days of AOL before any GUI interfaces. You are close. Bird of Prey + Priapism pretty much tells the story.

Based on the info from other users on this site, one can indeed just define the path. I think most people who mapped their drives allowing “reconnect on sign on” didn’t notice compared to those of us who started from start trying to map the drive and “browse” to the drive or “browse” to the network and found neither worked whereas those who started with original Windows 10 before the November “fix” had their pathways defined prior to the update preventing one from “mapping” or disappearing from the network thereby not even noticing.

I’m not sure if it’s intentional that you’re making yourself sound like an online sexual predator? :slight_smile: By the way, fellow medic? Radiologist?