Windows 10 Roon 1.8 not showing "Settings"


same happened here

I get the same screen without access to settings in MacOS High Sierra.

1 Like

Same here!

Same here Win 10

Set windows 10 language (language of your system, not inside roon) to English.
That did it for me.

The same here, no matter which language is chosen. No restart of the application or OS helps

Same here. Windows 10 Home Dutch.

As VolkerS wrote, as a workaround, the system language in Windows can be temporarily set to English. Then all settings are visible. Is of course not the solution.

Same issue on all my three different PCs on Win10. Rest of the system (NUC i7 as Core with ROCK and remote controlled by Samsung S10+, S8+ and Tab A 10’’ works fine - just iPhone 8 still has problems with display of “settings” - “info”). The Samsungs initially behaved similar after update. This could be solved by deleting (uninstall) the APP and complete new installation from Play-Store. Re-installation on the PCs and iPhone 8 didn’t work like that.

Forgot to mention: Language setting is German.

Same issue. Windows 10 Enterprise Dutch.

I have the same problem. I cannot access the settings options. Just the general options. Windows 10. Spanish language.
So far the Roon 1.8 update has been a real disaster.

Please help! What I can do?

Goto settings-language. Download English( united States). Restart and the problems are solved.

Same here. German Windows 10.

das gleiche…Albumformate werden auch nicht mehr angezeigt…Genre fehlen…Darstellung völlig daneben…usw.

Die Lösung kann doch nicht das Umstellen der Systemsprache sein…ich möchte keine Fremdsprache lernen sondern Musik hören und meine Bibliothek dargestellt haben.

Das Update ist, bei allem Respekt, völlig daneben!


First update today, the settings are now also visible and operable with German language settings. Thanks for the quick fix.

Happy again - the update solved the “settings” issue on my PCs under WIN10/64 - German
Well done :slight_smile:

and update on iPhone 8 works also fine again - :slight_smile:

Confirming the quick fix update has solved the issue ! Thank you for the quick and prompt fix !!