Windows Roon app closing [solved, asio4all causing issues]

I’ve tried the latest Roon app on my Win 10 64bit PC, but I’ve got a problem. Every time when I closed the Roon app by clicking the red cross button, the window closes yet the task process doesn’t end. And then if I’d like to run the app again, it doesn’t respond, unless I manually terminate the process. What should I do to solve the problem?

Did you install roonserver.exe or Roon.exe?

If roonserver then it runs as a service and is quit via the task bar.

Only the client quits with the X in the top corner.

No, not the server. The process is roon.exe.
For example, I run Roon, then I close it. Now I wanna listen to the music again. I double-click the Roon icon, but there won’t be a response. Of course there’s neither an opening UI nor a system tray icon. But there will be another roon.exe appear in the task manager. How many times I double-click, how many roon.exes will be increased in the task manager. But after that, no Roon window will appear, unless I terminate all the roon.exes and restart Roon.
Do you have any idea about that?

Now I’ve found that if I use ASIO driver (ASIO4ALL) to output, the problem occurs. It seems that the ASIO driver couldn’t be shut correctly, for as long as I disable the zone for it, things go well.

Yep, ASIO4ALL can cause issues.

But I’m wondering if there’s a solution to it, for now my board based Realtek ALC892 doesn’t even offer a native ASIO support (really hard to believe that). I’ve also tried ASIO2WASAPI. The closing problem didn’t occur but the volume is fixed in Roon so that the music volume is very low as well as not tunable. Really need a solution.

@Knyck_Volker Well, I had a similar issue.

I had a Windows 10 machine which I wanted to send the the music out via S/PDIF to my DAC. I had used ASIO4ALL as a solution. My main Windows machine has a dedicated sound card with its own native ASIO drivers and it works spectacularly. But this machine did not have the space to add in one of those, plus, unlike my main machine, the sound card portion was not producing the audio just sending out the digital output. I just stuck with the RealTek So when I first started using Roon back last spring, I ran into all sorts of issues with ASIO4ALL and really started researching it. Did not like what I found so I dropped it.

My Solution:
So, I found :(and I don’t remember how) that Microsoft has a set of High Definition Audio Native Device Drivers.
Driver Version: 10.0.10240.16384
Driver Date: 7/9/2015
I uninstalled all RealTek drivers. I installed the Microsoft driver. Setup the S/PDIF Digital out, by selecting the appropriate formats, setting the output level at 100, turning off all enhancements, checking the allow exclusive access buttons, and setting the shared native rate to 24/192. Works like a champ in Roon to send bit perfect out to my DAC. Now my volume is controlled by the amp and not by Roon.

Hope it may give you some ideas. BTW, those Microsoft HD Device Drivers work all the way back to 7 as well.

Now I use native WASAPI in exclusive mode and a virtual ASIO driver seems not that essential for Roon. WASAPI does perform well with the board-based sound card. But still, an external DAC or a DAW software requires an ASIO driver. At least ASIO4ALL is compatible with Pro Tools and Ableton Live in my PC.
PS I’ve googled your recommended driver yet can’t find an available download link. I’ll try it again later on. Cheers for your advice anyway.