Windows Server 2016 as the Core

Core Machine (Operating system/System info/Roon build number)

Windows Server 2016, all patched, latest Roon Server x64

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired Gigabit Ehternet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Nothing yet

Description Of Issue

Core server cannot be found by my Windows Roon client

Have you opened up both firewalls?

1 Like

How do I do that? Do I need to know port numbers etc?

Ok, ensured Windows client is allowed thru Norton 360. On the Windows Server 2016, I have added to the allowed apps in Windows Firewall.

Did you install the full Roon suite or just server? If going with the full suite route can you launch locally on the Windows PC?

1 Like

The full package won’t run on the server as the graphics card doesn’t support openGL so the standard package errors on startup. The advice here was to install the Server x64 package in order to run the Core.

Tried an iOS client - it can’t find the Core either

You added roon and RAATServer?
And they are all on the same subnet?

1 Like

Ah, I see that you put that in your initial post. Just for testing can you disable antivirus application on the server? Also both devices are on the same network?

1 Like

Ahah! I’ve disabled Windows Firewall on the server and the Core is now found. How do I enable the app in Windows Firewall? I thought I had…

I’ve “allowed” roonserver.exe in Windows Firewall. Do I need to add another exe?

Which apps did you let through? There are potentially 3 of them RoonAppliance, RoonServer and RAATServer.

To test, shutdown the firewalls completely on both machines and see if the remote can then see the server. And you should verify that all the devices are in the same subnet.

Further down the installation pipeline, Server might not have all the audio codecs, if not, you will have to install them yourself.

1 Like

O=Ah, that makes sense. Are they all in the Roon Applications folder?

I think RAATServer is in it’s own folder, I think


1 Like

Ok, you guys rock! I’ve enabled those three exe files in Windows Firewall and all is good! Wouldn’t UPnP be easier?

Hmm, maybe but not as good. If you care, take a dive into the forum and you can find some posts from years back where the devs explain their philosophy on UPnP and why RAAT.

BTW, Welcome to the forums! And, I’m just another user like you, a volunteer mod, not an official employee.

1 Like

But still, the fast replies have got me up and running in minutes - thank you all!!!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.