Wireless troubles

(Harry ten Berge) #1

Ok guys, different thread. Let’s keep this ‘wifi only’ :wink:

I’ve found out that one of the things that causes a crash happens when the regulatory domain is being set. Although it seems to recover from the crash, it’s far from ideal of course.

I’m working on a patch release that addresses this issue.

2 Likes
(Russ Baldwin) #2

Out RopieeeXL device just got rebooted and obviously picked up the new version, works fine wired, but nothing via Wireless (Internal Rpi3b). Prior to this it worked well with the internal WiFi…

Feedback: ba1d6e7f4e26c5f9;

RopieeeXL
ropieee 20190605-4
ropieee-version 281-1
ropieee-web 20190525-1
linux-raspberrypi-dsd 4.19.42-1
mosquitto-ropieee 1.5.8-1
qt5-base-ropieee 5.12.3-1
ropieee-remote 20190427-1

Anyone any ideas?

(Harry ten Berge) #3

yes. you’re using the beta channel, which does not have my latest fixes for wifi.

I’ll push an update to beta later today.

(Russ Baldwin) #4

Thanks Harry, when released I will test and let you know how it goes.

(Russ Baldwin) #5

OK Harry, updated but still no luck with Wireless, wired OK, feedback sent: dd51d846fd7d2316

Any ideas?

(Harry ten Berge) #6

have you reconfigured it?

(Russ Baldwin) #7

If you mean WiFi, yes, if I run configure from the command line I get an error…

*** setting up wired network
configure [31-ropieee_network_wireless]
*** setting up wireless network
*** wireless: WPA supplicant
*** psk: Removed
configure: 31-ropieee_network_wireless FAILED:
— BEGIN
base64: invalid input
base64: invalid input
— END
configure [32-ropieee_network_services]
*** restart network daemon

(Harry ten Berge) #8

No, not from the command line. Regular route, via the webpage.

(Russ Baldwin) #9

Yes I originally did it via the web page

(Harry ten Berge) #10

Ok. Can you do it via the webpage (and enter your PSK again as well!), and then send me feedback?

(Russ Baldwin) #11

Redone via webpage with PSK re-entered and feedback sent: 8166ae0ca1693d13

(Harry ten Berge) #12

Thanks for that. I know what it is. Sit tight, I’ll create a patch.

(Russ Baldwin) #13

You are a star Harry!

(Harry ten Berge) #14

update is ready, on the beta channel. Can you try?

(Russ Baldwin) #15

Yes that seems to work, at least I can see it only using Wireless and it appears in Roon. My son can test the music playing tomorrow, but I’m thinking that is going to be OK as it worked before.

Many thanks for your help Harry!

1 Like
(Harry ten Berge) #16

pushed out the fix from beta to stable as well.

(Russ Baldwin) #17

Harry, just to confirm, both Roon Raat and Airplay again play music via the RPi3b built in wireless with the lastest patched RopieeeXL.

There is still the weird volume thing it, where you have to use the Raat volume in conjunction with the Airplay volume to give you usable levels (as noted in the RopieeeXL thread), but we can live with that now we understand it.

Many thanks…