Won't install Roon Servers Build 106 [Resolved]

@support Roon downloads and attempts to install the new build 106 on Ropieee but fails as soon as it starts the update with a message “There was an error checking for an update”

Ok. As soon as I’m home I’ll have a look myself.

HI @Tony_Reimann tested this at home and everything updated fine.
I think you might have run into a brief problem when connection to the Roon infrastructure.

Can you try again?


I have tried 4 times with the same result. Will reinstall Ropieee from scratch and see how it goes.

Reinstalled Ropieee from scratch and all good.

1 Like

I ran into something similar on my linux-based bridge (Atom NUC). In my setup I have the Logs directory in the same filesystem as RoonBridge and RAATServer (the default setup). In my case with constant use (10 hrs/day 5 days/week) the RAAT Logs filled up the filesystem. That was causing the update to fail.

Cleaning out the logfiles allowed the update to complete normally. I need to update my config to either flush the logs on reboot or redirect them to /tmp, but haven’t gotten around to it.

I have the same issue, with update failing. Unfortunately totally noob when it comes to linux. CAn anybody briefly explain how to flush the log files? Thanks in advance!

Just to be sure: are you running RoPieee?

Yes, Ropieee. I installed the latest image (2017/08/19), Roon version is build 106 and it tries to install build 112.

For information, my SD is 2 Gb, could it be too small?

Ah. well, that indeed could mean it runs full because of the log files and then it can’t update.

So you’re on RoPieee’s stable build? Or are you running the beta?

Yes, running the stable build.

Ok. You stated that you’re a ‘total noob’ on linux. Do you have any experience with SSH?

yes, some. Have a SSH client installed. But really don’t know any commands…

ok. let’s go then:

  1. login with ssh to your ropieee with username ‘root’ and password ‘root’.
  2. run the following command:

rm -rf /var/roon/*/Logs/*

done, now run:


After the reboot of your RoPieee you can try to see if it will update.

I’m running RoPiee, how do I know that I have the latest software in it? I thought it updated automaticly? I have no Linux eperience and the plug and play aspect appealed to me. Thank you.

It updates automatically indeed. This is just a manual ‘fix’ to make sure your RoonBridge is capable updating, which is normally not required.

And I will build a fix for this as well.

With respect to which RoPieee your’re running: you can go the web page of ropieee (point your browser to: http://ropieee.local or replace ‘ropieee’ with the hostname you’ve given it). On the information tab you can see the version information.

Ok, did that now, after reboot I checked again, it downloads the update but unfortunately I get the same error message “There was an error checking for an update”…

ok. can you go to RoPieee’s web page, to the tab ‘advanced’ and hit the ‘send feedback’ button? I can then have a closer look why it fails to update RoonBridge.

Done. Here is the feedback identifier 5f98a9c93b721c6d

1 Like