X86 32 bit Linux RoonBridge still possible? [Resolved]

On the Roon downloads page it says “Roon Bridge for Linux runs on x86_64 and armv7hf and armv8 platforms.” without including the x86_32 version in that statement.

Below there is a downloadable .sh version available for 32 bit but no installers are listed in the “Easy Installer” options.

So far I am having no luck with the .sh script or the .tar on a 32 bit Intel x86 machine. I have been trying SSH remote as well as the terminal on the local Ubuntu install.

If someone could expand the details of this post with steps to enter in terminal I would appreciate it!

There is a Roon Bridge X86 32bit Linux Easy Install script. What happens when you run it ? You’ll need to install the dependencies.

Based on the ARCH variable in the script I would guess the commands to run the x86 easy installer script are:

$ curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxx86.sh
$ chmod +x roonbridge-installer-linuxx86.sh
$ sudo ./roonbridge-installer-linuxx86.sh

Edit: I think that the -O in the curl command is meant to be a -0 (numeric, not alphabetical).

-0, --http1.0
(HTTP) Tells curl to use HTTP version 1.0 instead of using its internally preferred HTTP version.
This option overrides –http1.1 and –http2.

Edit: Nope, I’m wrong, it is alphabetical O, see below.

Let’s flag @danny to check that syntax. A KB edit may be in order.

Hi Andy,

Depending on where and how I enter the commands I get various inconsistent responses.

Sometimes it reports my system is not compatible or:

-bash: line 7: ./roonbridge-installer-linuxx86.sh: Permission denied.

-bash: ./roonbridge-installer-linuxx86.sh: Permission denied

This OS is set allow administrator full permissions with my login.

I have tried placing the script in different places- root, Desktop, Opt, etc.

I have tried to execute this script and have extracted the contents of .tar and tried to execute both start.sh and check.sh.

Using Lubuntu with Putty, WinSCP and the terminal in the local desktop.

Beats me.

Let’s also flag @support and see if they can help.

Run it as root

You’ll need something along the lines of …

sudo apt install curl ffmpeg libasound2 cifs-utils
curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxx86.sh
chmod +x roonbridge-installer-linuxx86.sh
sudo ./roonbridge-installer-linuxx86.sh
sudo systemctl status roonbridge

The “-O” is correct… curl documentation states:

-O, --remote-name

Write output to a local file named like the remote file we get. (Only the file part of the remote file is used, the path is cut off.)

I think if you omit it, things will still work out, but it guarantees the remaining steps are using the correct filename.

1 Like

Yes, it is an ‘O’. Unfortunately, the monospace font makes it look like a zero … O.

1 Like

Thank you to everyone that has contributed their help!

The commands Martin_Webster posted are working fine. Unfortunately I am getting an error regarding system compatibility.

Error: This package is intended for x86 platforms. It is not compatible with your machine. Exiting.

This platform is x86 Intel and runs other distros like Vortexbox and the 32 bit version of Lubuntu I am testing this on now.

What’s the output from lscpu? 20k Bogomips doesn’t sound like a 32 bit CPU!

CPU op-mode(s): 32-bit
Byte Order: Little Endian
CPU(s): 2
On-line CPU(s) list: 0,1
Thread(s) per core: 2
Core(s) per socket: 1
Socket(s): 1
Vendor ID: GenuineIntel
CPU family: 6
Model: 28
Model name: Intel® Atom™ CPU N270 @ 1.60GHz
Stepping: 2
CPU MHz: 802.218
CPU max MHz: 1600.0000
CPU min MHz: 800.0000
BogoMIPS: 3192.04
L1d cache: 24K
L1i cache: 32K
L2 cache: 512K
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx constant_tsc arch_perfmon pebs bts cpuid aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 xtpr pdcm movbe lahf_lm dtherm

I think there might be an error in the 32bit script. It checks for a 64bit processor (same as the 64bit script) and exits when it can’t find one. Comparing the two they do the same _64 ARCH search, but it says ARCH=x86 in one and ARCH=x64 in the other. Is this meant as a 32bit install on a x86_64 architecture or is the script fauty? Maybe @danny or @brian can help clear this up?

Reading the KB it says here: https://kb.roonlabs.com/LinuxInstallRoon Bridge for Linux runs on x86_64 and armv7hf and armv8 platforms” so it seems you are out of luck on a 32bit Intel processor unfortunately. Sorry for the ‘false alarm’.

This brings the issue back to my first post. There was an announcement rolling out a 32 bit version and it is listed on the downloads page.

Can support clarify if it is defective?

I believe the KB text wasn’t updated when the 32 bit version was added to the downloads page and that @ogs first above post about the 64 bit check being unchanged is likely to be the problem. Someone more proficient in Linux than I am will confirm.

Thanks for letting us know…we recently changed the scripts for an unrelated reason–it’s possible that something broke. It is being looked into.


I am encouraged that we are making progress. :sunglasses: There are stacks of 32 bit machines here that will make nice endpoints.

Is this the best place to watch for news?

Yes. Roon staff will report back into this thread. Thanks for your patience and to the other users who have contributed.

1 Like

I re-read your first post. You say that also the tar archive failed to install. Did you retry this after you had the dependencies sorted?

I have been pulled away from this temporarily. I will certainly give that a try soon. Thanks again for your support!