Zerotier on iOS, can't see the iphone as the play zone?


Here is my setup:
Roon server on debian with Zerotier installed locally at home.
Have laptop in office with zerotier installed as well
Have iphone with zerotier installed as well, under 5G or wifi network.

Now the problem is the laptop in office can successfully link to roon server and play music, but on the iphone with 5G or Wifi network, I can connect to the roon server, but not able to setup the iphone as the play zone(end point), anybody have the solution about this situation?

Some thread on this forum mentioned iphone under wifi network should be able to play back the music, but I can’t …

Not knowing what Zerotier is, i might be misled here.
But if you can access your Roon Core with the phone (meaning you are on the same subnet) you can also set it up as an endpoint. Settings-Audio, top of screen…

Not a helpful post on my behalf, but that statement is not true, alas. You could reach a core while on a different subnet, but still not set it up as an endpoint.

There are ways to make it work, but honestly, it’s not worth the effort. No idea how to do it with zero tier though.

1 Like

Point is: Make em’ reside on the same subnet and don’t go near VPN, QoS or other technicalities and it will work. :slight_smile:

ZeroTier is an SD-LAN implementation, with an encrypted transport under the hood. By running it on your Roon Core, it looks like a “local” interface to Roon. Then you also run it on your Roon Remote machines, where it also appears as a “local” interface. It supports broadcast and multicast. Roon Remote works fine over it on basically every platform except iOS. Apple prevents ZeroTier from working correctly, because Apple. (From what I have read, I believe it will work when the iOS device is connected to a Wi-Fi network, but will never work over cellular.)

Solution: don’t use Apple lock-in junk. :slight_smile:

Thank you all for the replies!

Would wait for ROON 2.0 to have the mobile, hopefully:)